ProLiant Servers (ML,DL,SL)
cancel
Showing results for 
Search instead for 
Did you mean: 

HP DL380 G5 CPU load when using LAN

Hikxz
Occasional Visitor

HP DL380 G5 CPU load when using LAN

Hello. I have a HP DL380 G5 server & a have a problem. OS WS 2012 R2 installation proceeds normally, the installation takes the Hyper-V role well, but the virtual machines is running weird. When using a network inside a virtual machine (for example, copy of iso file from the network to virtual machine) CPU inside of the VM at 100%. 50-60% is process System interrupts. All terribly slow, up until the copy end. I do not know what to do. Maybe somebody faced with something similar?
I now what the Windows Server 2012 R2 is not supported on HP DL380 G5 server. I installed Windows Server 2008 R2 SP1 with SmartSrart CD. And got quite a similar situation. Nothing has changed.
I installed the latest service pack. SPP 2014.06. All firmwares are latest.
Server Name: ProLiant DL380 G5
Product ID: 417455-421
System ROM: P56  05/02/2011
iLO 2 Firmware Version: 2.25   04/14/2014
Smart Array P400 Controller: 7.24
Intel Xeon 5130 2.0 GHz * 2
Ram 32 Gb
Raid Smart Array P400i 512mb + battery
Network Broadcom BCM5708C 1 Gb * 2
Host OS - raid 1
VMs - raid 10

I tried to disable Large Send Offload, RSS and TCP Chimney on the NICs. And even put another network card with Intel chip. It does not change anything. I don`t use legacy adapter on a VMs.

Even if we exclude the Hyper-V. When copying from a network on the host server the first of the CPU loading by 35%. Could this be the problem directly with the hardware? Or is it just a feature of the work of these servers?

 

Thnx!

2 REPLIES
waaronb
Respected Contributor

Re: HP DL380 G5 CPU load when using LAN

I have 3 servers (soon to be 4) that are about the same as yours, except I'm not doing Hyper-V.

 

3 of them are DL360 G5's and one is a DL380 G5.  They're all running Windows Server 2012 R2 with all the latest HP and MS stuff.

 

I haven't seen any performance issues with the network card, or heavy interrupts during high periods of network traffic.  Like I said, I don't have the Hyper-V role installed so I don't know if that alone would make a difference.

 

How is your Hyper-V virtual switch setup?  Are you using one NIC for the Hyper-V virtual switch and also for host traffic, or are you dedicating one of the built-in NICs just to Hyper-V and using the other just for the host?

 

That might make a difference... maybe there's something strange in the way the Hyper-V vswitch was setup that's causing problems.  You could try removing it and re-creating it to get any virtual adapter stuff reset to defaults.

 

Also, make sure it's really using the most recent NIC drivers.  SPP 2014.06 should have the correct (working) version so I'm sure that's okay, but you could make sure.

 

Server 2012 R2 does seem to work okay on these... The only software I couldn't get on the DL360/380 G5 pages was for the ILO2 driver, but you can get a Server 2012 version of it from the DL360/380 G6 downloads... it does exist! :)

Hikxz
Occasional Visitor

Re: HP DL380 G5 CPU load when using LAN

Thanks for the answer!

I think that Hyper-V does not play a role here. I completely reinstall the operating system several times. Resets bios. You have the same processors?