ProLiant Servers (ML,DL,SL)

HP H221 SAS Card Stuck at Initializing When Connected to JBOD

Occasional Collector

HP H221 SAS Card Stuck at Initializing When Connected to JBOD

We recently purchased a ProLiant DL380p Gen8 to add as a third node to our Hyper-V cluster. It was specced to match the existing hardware, including an LSI SAS card. The part number on my quote indicates it's the 9207-8E. This is the same part number of the cards we bought about two years ago for the existing servers.

I set the system up as usual, installing Windows and the necessary drivers. After connecting the SAS card to our JBOD (DNS-1640), it wasn't seeing the storage. After adding the node to the failover cluster, I could run VMs on it but when trying to move storage to it, it errored with "Clustered storage is not available to this node."

After rebooting the node, it gets stuck during POST as it tries to initialize the card. It just spins. Screenshot here: If I unplug the SAS cables, after about 30 seconds, it boots normally.

The card was initially showed this version:

HP H200 Series SAS 2 Host Bus Adapter(s)

MPT2BIOS- (2011.07.29)

I upgraded the firmware on the card to the latest I could find on the HP website. It now shows:

Avago Technologies MPT SAS2 BIOS

MPT2BIOS- (2014.09.18)

Either way, same result. I also installed the Service Pack for ProLiant 2016.10.0 and updated all of the firmware, so everything should be on the latest. If there's anything specific to check, I can provide that.

I'm not super great with hardware, and when I set up the original two nodes I just plugged them in, installed Windows and it worked. I'm not even sure how to troubleshoot this. I've spun my wheels for hours so I was hoping someone had a suggestion or could point me in the right direction. Thanks.


EDIT: I forgot to mention I did RMA the card with Broadcom, thinking it might be a defective card. Same result with a new card. Tried different PCI slot, different cables, and different ports on the JBOD. All yield the same result.