ProLiant Servers (ML,DL,SL)
cancel
Showing results for 
Search instead for 
Did you mean: 

HP P410 “Parity Initialization Status: Initialization Failed” How to fix?

ispirto
Occasional Contributor

HP P410 “Parity Initialization Status: Initialization Failed” How to fix?

I'm using HP P410 raid card with BBU with 12 x 3TB drives on RAID50

 

After a power outage at the datacenter, the hpacucli shows this:

 

Parity Initialization Status: Initialization Failed

 

However, all the disks appear to be operational:

 

Parity Group 0:
physicaldrive 1I:1:1 (port 1I:box 1:bay 1, SATA, 3 TB, OK)
physicaldrive 1I:1:2 (port 1I:box 1:bay 2, SATA, 3 TB, OK)
physicaldrive 1I:1:3 (port 1I:box 1:bay 3, SATA, 3 TB, OK)
physicaldrive 1I:1:4 (port 1I:box 1:bay 4, SATA, 3 TB, OK)
physicaldrive 1I:1:5 (port 1I:box 1:bay 5, SATA, 3 TB, OK)
physicaldrive 1I:1:6 (port 1I:box 1:bay 6, SATA, 3 TB, OK)


Parity Group 1:
physicaldrive 1I:1:7 (port 1I:box 1:bay 7, SATA, 3 TB, OK)
physicaldrive 1I:1:8 (port 1I:box 1:bay 8, SATA, 3 TB, OK)
physicaldrive 1I:1:9 (port 1I:box 1:bay 9, SATA, 3 TB, OK)
physicaldrive 1I:1:10 (port 1I:box 1:bay 10, SATA, 3 TB, OK)
physicaldrive 1I:1:11 (port 1I:box 1:bay 11, SATA, 3 TB, OK)
physicaldrive 1I:1:12 (port 1I:box 1:bay 12, SATA, 3 TB, OK)

 

I couldn't find anything about an error in the ADU report.

 

The server is in production and I'm scared of loosing the data because parity is not online it seems. What can I do to reinitialize parity initialization?

 

If I do hpacucli ctrl slot=0 ld 2 modify raid=50, would I loose the data or will it just restart the initialization?

 

Here is the complete hpacucli output: http://pastebin.com/raw.php?i=19YJ6aWF

 

Here is the ADU report: https://www.dropbox.com/s/dyptmea8z3qwlsq/ADU%20Report%20Viewer.html

3 REPLIES
PeterPalm
Occasional Visitor

Re: HP P410 “Parity Initialization Status: Initialization Failed” How to fix?

We've got the same problem here, the operating system reports errors like:

end_request: I/O error, dev cciss/c0d0, sector 24411088

But all physical disks are ok.

 

Did you find a solution for your (and my) problem?

 

 

 

chaos-prevails
Occasional Visitor

Re: HP P410 “Parity Initialization Status: Initialization Failed” How to fix?

I know this is an old thread, but I face the same problem:

SmartArray P800 with 8x 500GB disks as Raid 5.

All drives show fine, both on hpacucli and smart (also, all drives finished successfully the SMART long test)

The controller crashed about 14 days ago (the second time already), but all showed up fine afterwards. Then about 7 days ago I get a "Parity Initialization Status: Initialization Failed" (I get daily status mail of controller, LD and PD)

Up until now no change. I wonder how I could force a reinitialization of the Parity?

I didn't find any command how to reinitialize parity. Is this happening automatically? Do I need to restart the server so the controller starts reinitialization? It's not a mission critical server, but nevertheless I would like to see this fixed.

I had a drive failure about 1 month ago (same controller, different logical drive). I exchanged the drive, logical drive started recovery, and then initailized parity. Took some time but eventually finished.
In the course of this drive failure, I changed Surface Scan Delay to 3 seconds to speed up initialization.

chaos-prevails
Occasional Visitor

Re: HP P410 “Parity Initialization Status: Initialization Failed” How to fix?

Hello,

in case this helps anyone, I can reply to my own question.

It "solved" itself after 16 days. Without any server restart or other intervention. I just used the server as before. It's the second time I have this happening on this server (see chronology). For me it seems the parity is messed up with the controller crash, and then re-initialized automatically in the background (but not showing in HP health). Or probably it's not messed up but the controller has to re-check whether everything is OK.

The chronology is:

=== Incident 1 ===
2017-03-22: controller crash
-- iLO logs: Host server reset by: ADMIN
-- IML logs: POST Error: 1778-Drive Array Resuming Automatic Data Recovery Process

--> + 6 days -->
2017-03-28: Parity Initialization Status: Initialization Failed
(I assume due to controller crash on march 22nd)

--> + 8 days -->
        2017-04-05 10:19: controller crash
        -- IML logs: POST Error: 1792-Drive Array Reports Valid Data Found in Array Accelerator

--> + 31 days -->
2017-05-06: Parity Initialization Status: Initialization Completed <-- FIXED

=== Incident 2 ===
2017-11-28: controller crash
-- iLO logs: Host server reset by: ADMIN
-- IML logs: POST Error: 1792-Drive Array Reports Valid Data Found in Array Accelerator

--> + 8 days -->
2017-12-06: Parity Initialization Status: Initialization Failed
(I assume due to controller crash on November 28th)

--> + 16 days -->
2017-12-24: Parity Initialization Status: Initialization Completed <-- FIXED