ProLiant Servers (ML,DL,SL)
cancel
Showing results for 
Search instead for 
Did you mean: 

HP P420 Firmware Flash

 
Joe-Phillips
Occasional Contributor

HP P420 Firmware Flash

HI All,

Apologies if I have posted this in the wrong place. I couldn't find a location for storage controllers specifically.

I have a HP P420 Smart Array Controller in a HP Proliant ML310e Gen8, which is being recognised in the BIOS but is not being recognised in the HP SmartArray Configuration utility. I have a feeling the firmware on the card may be corrupted...

I have attempted to flash the firmware on the card via HP SPP but it gives an error (see below). When the SPP highlights that the controller requires an update the current version of firmware is blank. I have tried using the advanced options of rewrite, downgrade etc which produces the same error

Exit Status: 3
Update not attempted. All selected devices are either up-to-date or have new versions installed.

I have also booted a CentOS 7 liveCD and attempted to flash the firmware in terminal with all the switches for rewrite, downgrade, force but still it produces the same error as above

Is the controller broken and I am wasting my time, or is there a way I could flash the firmware back and salvage the card?

Any suggestions would be greatly appreciated.

Thanks in advance

Joe

6 REPLIES 6
parnassus
Honored Contributor

Re: HP P420 Firmware Flash

Which firmware your HP Smart Array P420 is currently runnning on? 8.32(C) is the latest released IIRC...anyway also 8.32 is good enough.

Which version is the HP Smart Array Configuration Utility (are you using that utility at OS level?)?

Joe-Phillips
Occasional Contributor

Re: HP P420 Firmware Flash

Hi There,


Thanks for the reply. This is the thing, the current firmware shows up as blank, which is what made me think it might be corrupted.

I have tried the SmartArray Utility via HP Proliant Intelligent Provisioning, HP Proliant Service Pack 2017, 2018 and 2019 all show the same issue. There is currently no OS installed as it is a server I have been putting together out of spares.

The card was a spare I had in a box, I guess it could be dead. I just hoped I could revive it :(

 

Joe-Phillips
Occasional Contributor

Re: HP P420 Firmware Flash

Hi All,

Seems I have found the problem. I have removed the 2GB FWBC module and there server is seeing the controller. Seems the FWBC is faulty.

EDIT: I had a spare FWBC module which when inserted makes the card invisible again. I guess the controller is dead :(

Joe-Phillips
Occasional Contributor

Re: HP P420 Firmware Flash

Update:

I have a managed to get the following error during POST for the card... Any ideas?

Slot 2 HP Smart Array P420 Controller

1783-Slot 2 Driver Array Controller Failure!

[Self-Test failure (cmd=0h, eer=00h lockup=0DEAD : DEADh)]

 

parnassus
Honored Contributor

Re: HP P420 Firmware Flash

Joe-Phillips
Occasional Contributor

Re: HP P420 Firmware Flash

Hi Again

That error was displayed with the either of the two FWBC modules & battery seated on the controller.

I did see the post you mentioned before posting on this board but was unable to make any progress.

With the FWBC disconnected, I can update the firmware on the controller to the latest 8.32 revision and I can see it within the smart array utility, albeit the card is disabled without a cache module installed.

As soon as my 1GB or 2GB cache module & battery are seated on to the controller the self test error occurs, which I assume means the card is dead and I’ll have to go shopping for a replacement :-(