ProLiant Servers (ML,DL,SL)
cancel
Showing results for 
Search instead for 
Did you mean: 

HP Teaming to Cisco Swich, trunking VLANS

 
Karl Newick
Occasional Contributor

HP Teaming to Cisco Swich, trunking VLANS

I am trying to setup a team on a DL360 g6 and a Cisco C-3750 Stack

I want to use it in a trunk so I can use a couple of VLANs to the server.

This is my config what I use for ESXi and works fine.
interface Port-channel9
description CVMC-eCW-DB1
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 10,70
switchport mode trunk

interface GigabitEthernet1/0/12
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 10,70
switchport mode trunk
channel-group 9 mode on
spanning-tree portfast

interface GigabitEthernet2/0/12
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 10,70
switchport mode trunk
channel-group 9 mode on
spanning-tree portfast

I can't get any traffic to pass. Has anyone done this?
6 REPLIES
CLEB
Valued Contributor

Re: HP Teaming to Cisco Swich, trunking VLANS

Have you tried changing your vswitch to route based on ip hash?
Karl Newick
Occasional Contributor

Re: HP Teaming to Cisco Swich, trunking VLANS

I'm sorry I should have said, this is to a windows 2008 R2 server using the HP NIC teaming.

I meant I have this working with the above config to other servers.. i.e ESXi

Sorry for the confusion.
CLEB
Valued Contributor

Re: HP Teaming to Cisco Swich, trunking VLANS

I have a port channel to a DL380G5 and Cisco 6509 switch modules.

When I get a chance I'll check the config.

I presume you've set the load balancing to 802.3ad Dynamic with Fault Tolerance?
CLEB
Valued Contributor

Re: HP Teaming to Cisco Swich, trunking VLANS

I have channel-group mode passive.
Karl Newick
Occasional Contributor

Re: HP Teaming to Cisco Swich, trunking VLANS

I have tried the following,

interface Port-channel9
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 10,70
switchport mode trunk
end


interface GigabitEthernet1/0/12
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 10,70
switchport mode trunk
channel-group 9 mode passive
spanning-tree portfast
end

!
interface GigabitEthernet2/0/12
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 10,70
switchport mode trunk
channel-group 9 mode passive
spanning-tree portfast
end

And set the NIC teaming to 802.3ad Dynamic.

Still nothing! Any thoughts?
CLEB
Valued Contributor

Re: HP Teaming to Cisco Swich, trunking VLANS

Disconnect the server nics. Bounce the ports and then the port channel interface.

Then reconnect the server.

If it still doesn't work and your running the latest drivers and firmware then I'm not sure.