cancel
Showing results for 
Search instead for 
Did you mean: 

HP iLO v4

Niroa
Advisor

HP iLO v4

We have HP proliant 350ML gen8 server and centos installed in it.

Yesterday morning it stop internet connecting process. Every time server restart I see iLO v 4 IP unknown.

then I set iLO to default. but no good thing happened.  When I restart the server the internet connection is back to normal, but after 2 minutes it is getting lost.

I disabled HP iLO by pressing F8 and disabled. Now the F8 option is invisible and nothing happens when I press F8.

How to re-enable iLO in my HP server?

14 REPLIES
Torsten.
Acclaimed Contributor

Re: HP iLO v4

I don't understand if your network problem is with OS or ILO.

 

However, to enable ILO again toggle dip switch 1 at the system maintenance switch on the system board.


Hope this helps!
Regards
Torsten.

__________________________________________________
There are only 10 types of people in the world -
those who understand binary, and those who don't.

__________________________________________________
No support by private messages. Please ask the forum!

If you feel this was helpful please click the KUDOS! thumb below!   
Jimmy Vance
HPE Pro

Re: HP iLO v4


Niroa wrote:

Yesterday morning it stop internet connecting process. Every time server restart I see iLO v 4 IP unknown.


iLO v4 IP unknown generally means you dont have iLO connected to the network, or there isn't a DHCP server on the network to provide an IP to iLO.  iLO connectivity has nothing to do wth the host OS not being able to communicate with the network.


Niroa wrote:

I disabled HP iLO by pressing F8 and disabled. Now the F8 option is invisible and nothing happens when I press F8.
How to re-enable iLO in my HP server?


To re-enable iLO on a Gen8 ProLiant:

1) Power off system and remove power.  Open case and set sw1 of the maintenance switch to the ON position. refer to decal inside case cover for position of switch.

2) power system on and press F8 to access iLO when prompted. under Settings - Confuigure ENABLE iLO Functionality and iLO4 ROM based Setup Utility

3) Exit and once iLO resets and the server continues through POST, power off, set SW1 back to off.

4) After replacing case cover, power server back on

 

 




__________________________________________________
No support by private messages. Please ask the forum!      I work for HPE

If you feel this was helpful please click the KUDOS! thumb below!   
Niroa
Advisor

Re: HP iLO v4

i enabled it. thanks very much. but still ip status is unknown in bios.

MY CONFIG IS :

1. DHCP enabled

2. selected public ethernet adapter in intelligent Provisioning.

 

 

Torsten.
Acclaimed Contributor

Re: HP iLO v4

Do you have a DHCP server that can serve the DHCP request?


Hope this helps!
Regards
Torsten.

__________________________________________________
There are only 10 types of people in the world -
those who understand binary, and those who don't.

__________________________________________________
No support by private messages. Please ask the forum!

If you feel this was helpful please click the KUDOS! thumb below!   
Niroa
Advisor

Re: HP iLO v4

yes, the router

Jimmy Vance
HPE Pro

Re: HP iLO v4

Do you have a network cale pluggend into the iLO network port?  Is iLO in dedicated (default) or shared network mode? If I recall that server has two embedded NICs for the Host OS, and one dedicated port for iLO




__________________________________________________
No support by private messages. Please ask the forum!      I work for HPE

If you feel this was helpful please click the KUDOS! thumb below!   
Niroa
Advisor

Re: HP iLO v4

No. there is no iLO port. Only two network ports for eth1 and eth2.

But there is an iLO ip version at the boot process.

 

Sorry for the comment hearder. We have HP proliant ML310e gen8 server.

sorry for the inconvenience.

Torsten.
Acclaimed Contributor

Re: HP iLO v4

The dedicated port for ML310e Gen8 is optional, for ML310e Gen8 v2 is is always installed.

 

So NIC1 is the shared port for ILO per default.


Hope this helps!
Regards
Torsten.

__________________________________________________
There are only 10 types of people in the world -
those who understand binary, and those who don't.

__________________________________________________
No support by private messages. Please ask the forum!

If you feel this was helpful please click the KUDOS! thumb below!   
Niroa
Advisor

Re: HP iLO v4

that means should i configure eth1 as the outside ip (connected to router).

that is the intilialized shared connector?

Jimmy Vance
HPE Pro

Re: HP iLO v4

The port labeled Port 1 is the shared iLO port. Some OS's will call Port 1 eth1 and port 2 eth0 instead of what you would expect as port 1 being eth0 and port 2 being eth1




__________________________________________________
No support by private messages. Please ask the forum!      I work for HPE

If you feel this was helpful please click the KUDOS! thumb below!   
Niroa
Advisor

Re: HP iLO v4

You mean the first ethernet adaptor must be used by iLO for share the network. And that adapter also should be connected with router to connect internet?
Torsten.
Acclaimed Contributor

Re: HP iLO v4

(9) optional ILO

(10) NIC1 / shared ILO

(11) NIC2

 

So you need a cable connected to NIC1.

 

The OS and ILO are using this connection, each with an own IP address. AFAIR the limitation is that the OS cannot ping or access the ILO over this shared connection.

 

HP ProLiant ML310e Gen8 Server Maintenance and Service Guide - Foxit Reader.jpg


Hope this helps!
Regards
Torsten.

__________________________________________________
There are only 10 types of people in the world -
those who understand binary, and those who don't.

__________________________________________________
No support by private messages. Please ask the forum!

If you feel this was helpful please click the KUDOS! thumb below!   
Niroa
Advisor

Re: HP iLO v4

Yes, this is the exact view of back of our server.
I will try this config and let you know. Thanks
Niroa
Advisor

Re: HP iLO v4

I changed the ethernet 1 to ethernet 2. Now it is ok with the internet and local hosts. everyone can works as it was before.

but iLO IP is still unknown.

thanks for the help