ProLiant Servers (ML,DL,SL)
cancel
Showing results for 
Search instead for 
Did you mean: 

HPE e208i-p Second array not visible in windows 2016

 
BigFred
Occasional Visitor

HPE e208i-p Second array not visible in windows 2016

I have a DL20 gen10 with the Smart Array e208i-p. I have 2SSD and 2 Sata HDD. I created 2 array with 2 logical volume. After installing windows using Intelligent Provisioning, only the first volume where the system is installed is visible in Windows. The second volume doesn’t sho up neither on hardware list, neither in the disk management...

Any idea ?

Thanks
8 REPLIES 8
R_Raj
HPE Pro

Re: HPE e208i-p Second array not visible in windows 2016

Hello,

With the available information, its quite difficult to answer the cause as lot of factors can lead to such situation like legacy or UEFI boot . There are limitations in Legacy boot mode where Max size of the partition has to be less than 2TB .UEFI doesn't have any such limitations.

In case if the server is in UEFI and the issue is the same we will have to investigate the cause . We will suggest logging a ticket with HPE support team to investigate the issue with the supported logs.

Regards

 


Accept or Kudo
BigFred
Occasional Visitor

Re: HPE e208i-p Second array not visible in windows 2016

Sorry for the lack of details...

so the boot is set as UEFI

the first array is made of 2 SSD of 256 GB in Raid 1

the second array is made of 2 HDD of 1TB in Raid 1

in the Provisioning tool, I see both array, in other systems I see both array, but in Windows I see only one...

I tried also to install Windows 2016 from the CD using the Smart array controller driver and I see only one drive (the second array doesn't show up)

 

Bios and other firmware are up to date...

I tried with a H240 controller and I have both array/volume showing up in Windows ... so it might be related to the raid controller...

 

 

 

pitchie
Occasional Visitor

Re: HPE e208i-p Second array not visible in windows 2016

Did you get to the bottom of this? I am having the same issue today with the same controller.

Logical drives created in Smart Storage. I have 3 drives.

One SSD Raid 0 drive for the O/S which works fine and the O/S is installed - 2 SSDs
One SSD Raid 5 drive. I can see the raid and logical drive in the Storage Administrator in Intelligent Provisioning but I cannot see it in Windows.
Then problem same again as the Raid 5 array, only this third array is a Raid 0 Sata array.

Any help would be appreciated.

Thanks.

Anonymous_User1
Not applicable

Re: HPE e208i-p Second array not visible in windows 2016

Have you both gone into Windows disk management to bring the second array online and create a volume?
pitchie
Occasional Visitor

Re: HPE e208i-p Second array not visible in windows 2016

Hi, it was the firmware of the controller. It was on version 1.4 and HPE support sent me 1.99 within SPP 0919 and it worked straight away.

florianknirsch
Occasional Visitor

Re: HPE e208i-p Second array not visible in windows 2016

i was running today into the same issue.

array 1 (2 ssd drives) and array 2 (2 hd drives) were both visible and working on windows2019 server essentials.

i applied then the hpe  service pack 1 and after reboot only array 1 is still there. 

@pitchie where did you get the correct firmware from? form hpe directly or is available on to download?

florianknirsch
Occasional Visitor

Re: HPE e208i-p Second array not visible in windows 2016

@pitchie  ok, i think i found it myself here:

https://support.hpe.com/hpsc/swd/public/detail?swItemId=MTX_cde91554cb5f4485873010b075&swEnvOid=4249

i will try it tomorrow and will see if it solves the issue.

 

Highlighted
florianknirsch
Occasional Visitor

Re: HPE e208i-p Second array not visible in windows 2016

I just tried to install the 1.99 firware from:

https://support.hpe.com/hpsc/swd/public/detail?swItemId=MTX_cde91554cb5f4485873010b075&swEnvOid=4249#

But i get a blues screen then.

So i have stil the old version on.:

HPE Smart Array E208i-p SR Gen10 : 1.04

https://photos.app.goo.gl/EbWjP3kMkdrnV63J7

when i launch the SPP from the iso:

P19473_001_spp-2019.09.0-SPP2019090.2019_0905.39.iso

it loads in the browser and then loads the libary and at some point i get as well a blue screen.

As this server needs to run in production i guess i rather need to raise a call to HP Support:

 

OS is Windows Server 2019 Essentials  Version 1809

below the full system summary:

System ROM : U44 1.22 4/4/2019
Redundant System ROM : U44 1.22 4/4/2019
Power Management Controller Firmware : 1.0.7
Power Management Controller Firmware Bootloader : 1.1
System Programmable Logic Device : 0xB
Server Platform Services (SPS) Firmware : 5.0.3.107.0
Intelligent Platform Abstraction Data : 7.14.0 Build 11
Intelligent Provisioning : 3.31.63
Embedded Video Controller : 2.5
HPE Smart Array S100i SR Gen10 : 2.02-0
HPE Ethernet 1Gb 2-port 332i Adapter - NIC : 20.14.54
HPE Smart Array E208i-p SR Gen10 : 1.04
iLO Firmware : 1.45B(0x6,0x0)
USB Vendor ID : 0x3F0
USB Class Code : Human Interface Device
USB Product ID : 0x94A
Location : Smsc USB 0
Name : Unknown Device
UEFI Device Path : PciRoot(0x0)/Pci(0x14,0x0)/USB(0x7,0x0)
USB Vendor ID : 0x424
USB Class Code : Hub Device
USB Sub Class and Protocol : Hi-speed hub with single TT
USB Product ID : 0x2660
b Vendor ID : 103C
PCI Sub Device ID : 22E8
PCI Class Code : 02
PCI Sub Class Code : 00
Firmware : 20.14.54
Location : Embedded SATA Controller #1
Slot Description : Embedded
UEFI Device Path : PciRoot(0x0)/Pci(0x17,0x0)
UEFI Structured Name : SATA.Emb.1.1
Populated : Yes
Enabled : Yes
Device Name : Embedded SATA Controller #1
Device Type : Storage Controller
PCI Address : Bus: 0, Device: 23, Function: 0
PCI Vendor ID : 8086
PCI Device ID : A356
PCI Sub Vendor ID : 1590
PCI Sub Device ID : 028C
PCI Class Code : 01
PCI Sub Class Code : 04
Firmware : N/A
Location : Embedded Storage
Slot Description : Embedded
UEFI Device Path : PciRoot(0x0)/Pci(0x1C,0x0)/Pci(0x0,0x7)
UEFI Structured Name : SWRAID.Emb.1.1
Populated : Yes
Enabled : Yes
Device Name : HPE Smart Array S100i SR Gen10
Device Type : Dynamic Smart Array Controller
PCI Address : Bus: 1, Device: 0, Function: 7
PCI Vendor ID : 103C
PCI Device ID : 193F
PCI Sub Vendor ID : 1590
PCI Sub Device ID : 00E4
PCI Class Code : 01
PCI Sub Class Code : 04
Firmware : 2.02-0
Location : Embedded Device
Slot Description : Embedded
UEFI Device Path : PciRoot(0x0)/Pci(0x1C,0x0)/Pci(0x0,0x1)
UEFI Structured Name : PCI.Emb.1.1
Populated : Yes
Enabled : Yes
Device Name : Embedded Video Controller
Device Type : PCI Device
PCI Address : Bus: 1, Device: 0, Function: 1
PCI Vendor ID : 102B
PCI Device ID : 0538
PCI Sub Vendor ID : 1590
PCI Sub Device ID : 00E4
PCI Class Code : 03
PCI Sub Class Code : 00
Firmware : 2.5
Location : PCI-E Slot 4
Slot Description : PCI Express Gen 3
Data Width : x4
Negotiated Link Width : x0
Mechanical Width : Short
UEFI Device Path : PciRoot(0x0)/Pci(0x1C,0x4)/Pci(0x0,0x0)
UEFI Structured Name : PCI.Slot.4.1
Populated : No
Location : PCI-E Slot 3
Slot Description : PCI Express Gen 3
Data Width : x4
Negotiated Link Width : x4
Mechanical Width : Long
UEFI Device Path : PciRoot(0x0)/Pci(0x1D,0x0)/Pci(0x0,0x0)
UEFI Structured Name : RAID.Slot.3.1
Populated : Yes
Enabled : Yes
Device Name : HPE Smart Array E208i-p SR Gen10
Device Type : Smart Array Storage Controller
PCI Address : Bus: 6, Device: 0, Function: 0
PCI Vendor ID : 9005
PCI Device ID : 028F
PCI Sub Vendor ID : 103C
PCI Sub Device ID : 0650
PCI Class Code : 01
PCI Sub Class Code : 07
Firmware : 1.04
Location : NVMe Slot
Slot Description : <null string>
Data Width : x2
Negotiated Link Width : x0
Mechanical Width : Other
UEFI Device Path : PciRoot(0x0)/Pci(0x1B,0x2)/Pci(0x0,0x0)
UEFI Structured Name : NVMe.Emb.1.1
Populated : No
Location : PCI-E Slot 2
Slot Description : PCI Express Gen 3
Data Width : x4
Negotiated Link Width : x0
Mechanical Width : Short
UEFI Device Path : PciRoot(0x0)/Pci(0x1B,0x4)/Pci(0x0,0x0)
UEFI Structured Name : PCI.Slot.2.1
Populated : No
Location : PCI-E Slot 1
Slot Description : PCI Express Gen 3
Data Width : x16
Negotiated Link Width : x0
Mechanical Width : Long
UEFI Device Path : PciRoot(0x0)/Pci(0x1,0x0)/Pci(0x0,0x0)
UEFI Structured Name : PCI.Slot.1.1
Populated : No