ProLiant Servers (ML,DL,SL)
cancel
Showing results for 
Search instead for 
Did you mean: 

Having issues installing hp-snmp-agent

richpp
Occasional Contributor

Having issues installing hp-snmp-agent

First time post!

Having difficulties installing hp-snmp-agent and other hp-health items on HPDL380G6.

Dependency issues.  OS is CentOS 7.2.  I see one of the dependencies.  Is there a single place to obtain all the dependencies required to install the HP Health tools?

--------------dependency issues----------------------

[root@svrdldws01 hp]# yum localinstall hp-snmp-agents-10.20-2789.26.rhel7.x86_64.rpm Loaded plugins: fastestmirror Setting up Local Package Process Examining hp-snmp-agents-10.20-2789.26.rhel7.x86_64.rpm: hp-snmp-agents-10.20-2789.26.rhel7.x86_64 Marking hp-snmp-agents-10.20-2789.26.rhel7.x86_64.rpm to be installed Loading mirror speeds from cached hostfile * base: centos.mia.host-engine.com * extras: mirror.us.leaseweb.net *

updates: dist1.800hosting.com Resolving Dependencies --> Running transaction check ---> Package hp-snmp-agents.x86_64 0:10.20-2789.26.rhel7 will be installed --> Processing Dependency: hp-health >= 9.1.0 for package: hp-snmp-agents-10.20-2789.26.rhel7.x86_64 --> Processing Dependency: libc.so.6(GLIBC_2.14)(64bit) for package: hp-snmp-agents-10.20-2789.26.rhel7.x86_64 --> Processing Dependency: net-snmp for package: hp-snmp-agents-10.20-2789.26.rhel7.x86_64 --> Processing Dependency: libhpasmintrfc64.so.3()(64bit) for package: hp-snmp-agents-10.20-2789.26.rhel7.x86_64 --> Processing Dependency: libhpev64.so.1()(64bit) for package: hp-snmp-agents-10.20-2789.26.rhel7.x86_64 --> Processing Dependency: libnetsnmp.so.31()(64bit) for package: hp-snmp-agents-10.20-2789.26.rhel7.x86_64 --> Processing Dependency: libnetsnmpagent.so.31()(64bit) for package: hp-snmp-agents-10.20-2789.26.rhel7.x86_64 --> Processing Dependency: libnetsnmpmibs.so.31()(64bit) for package: hp-snmp-agents-10.20-2789.26.rhel7.x86_64 --> Processing Dependency: librpm.so.3()(64bit) for package: hp-snmp-agents-10.20-2789.26.rhel7.x86_64 --> Processing Dependency: librpmio.so.3()(64bit) for package: hp-snmp-agents-10.20-2789.26.rhel7.x86_64 --> Processing Dependency: libsensors.so.4()(64bit) for package: hp-snmp-agents-10.20-2789.26.rhel7.x86_64 --> Running transaction check ---> Package hp-health.x86_64 0:10.30-1752.15.rhel7 will be installed ---> Package hp-snmp-agents.x86_64 0:10.20-2789.26.rhel7 will be installed --> Processing Dependency: libc.so.6(GLIBC_2.14)(64bit) for package: hp-snmp-agents-10.20-2789.26.rhel7.x86_64 --> Processing Dependency: libnetsnmp.so.31()(64bit) for package: hp-snmp-agents-10.20-2789.26.rhel7.x86_64 --> Processing Dependency: libnetsnmpagent.so.31()(64bit) for package: hp-snmp-agents-10.20-2789.26.rhel7.x86_64 --> Processing Dependency: libnetsnmpmibs.so.31()(64bit) for package: hp-snmp-agents-10.20-2789.26.rhel7.x86_64 --> Processing Dependency: librpm.so.3()(64bit) for package: hp-snmp-agents-10.20-2789.26.rhel7.x86_64 --> Processing Dependency: librpmio.so.3()(64bit) for package: hp-snmp-agents-10.20-2789.26.rhel7.x86_64 ---> Package lm_sensors-libs.x86_64 0:3.1.1-17.el6 will be installed ---> Package net-snmp.x86_64 1:5.5-54.el6_7.1 will be installed --> Processing Dependency: net-snmp-libs = 1:5.5-54.el6_7.1 for package: 1:net-snmp-5.5-54.el6_7.1.x86_64 --> Processing Dependency: libnetsnmptrapd.so.20()(64bit) for package: 1:net-snmp-5.5-54.el6_7.1.x86_64 --> Processing Dependency: libnetsnmpmibs.so.20()(64bit) for package: 1:net-snmp-5.5-54.el6_7.1.x86_64 --> Processing Dependency: libnetsnmphelpers.so.20()(64bit) for package: 1:net-snmp-5.5-54.el6_7.1.x86_64 --> Processing Dependency: libnetsnmpagent.so.20()(64bit) for package: 1:net-snmp-5.5-54.el6_7.1.x86_64 --> Processing Dependency: libnetsnmp.so.20()(64bit) for package: 1:net-snmp-5.5-54.el6_7.1.x86_64 --> Running transaction check ---> Package hp-snmp-agents.x86_64 0:10.20-2789.26.rhel7 will be installed --> Processing Dependency: libc.so.6(GLIBC_2.14)(64bit) for package: hp-snmp-agents-10.20-2789.26.rhel7.x86_64 --> Processing Dependency: libnetsnmp.so.31()(64bit) for package: hp-snmp-agents-10.20-2789.26.rhel7.x86_64 --> Processing Dependency: libnetsnmpagent.so.31()(64bit) for package: hp-snmp-agents-10.20-2789.26.rhel7.x86_64 --> Processing Dependency: libnetsnmpmibs.so.31()(64bit) for package: hp-snmp-agents-10.20-2789.26.rhel7.x86_64 --> Processing Dependency: librpm.so.3()(64bit) for package: hp-snmp-agents-10.20-2789.26.rhel7.x86_64 --> Processing Dependency: librpmio.so.3()(64bit) for package: hp-snmp-agents-10.20-2789.26.rhel7.x86_64 ---> Package net-snmp-libs.x86_64 1:5.5-54.el6_7.1 will be installed --> Finished Dependency Resolution Error: Package: hp-snmp-agents-10.20-2789.26.rhel7.x86_64 (/hp-snmp-agents-10.20-2789.26.rhel7.x86_64) Requires: librpmio.so.3()(64bit) Error: Package: hp-snmp-agents-10.20-2789.26.rhel7.x86_64 (/hp-snmp-agents-10.20-2789.26.rhel7.x86_64) Requires: libnetsnmpmibs.so.31()(64bit) Error: Package: hp-snmp-agents-10.20-2789.26.rhel7.x86_64 (/hp-snmp-agents-10.20-2789.26.rhel7.x86_64) Requires: libnetsnmpagent.so.31()(64bit) Error: Package: hp-snmp-agents-10.20-2789.26.rhel7.x86_64 (/hp-snmp-agents-10.20-2789.26.rhel7.x86_64) Requires: libnetsnmp.so.31()(64bit) Error: Package: hp-snmp-agents-10.20-2789.26.rhel7.x86_64 (/hp-snmp-agents-10.20-2789.26.rhel7.x86_64) Requires: librpm.so.3()(64bit) Error: Package: hp-snmp-agents-10.20-2789.26.rhel7.x86_64 (/hp-snmp-agents-10.20-2789.26.rhel7.x86_64) Requires: libc.so.6(GLIBC_2.14)(64bit) You could try using --skip-broken to work around the problem You could try running: rpm -Va --nofiles --nodigest