ProLiant Servers (ML,DL,SL)

Help Needed. Embedded Diagnose and Intelligent Provisioning Broken After Firmware Update

 
SOLVED
Go to solution
AngusHK
Occasional Visitor

Help Needed. Embedded Diagnose and Intelligent Provisioning Broken After Firmware Update

I have a MS Gen10 Plus.

I could not find any info online and I didnt know what happened.

IP has been working fine and today I realised there was a new firmware version

https://support.hpe.com/hpesc/public/swd/detail?swItemId=MTX_ca7d56ce4be149b1b4754b15f6

I wrote the iso into a USB drive and it did everything on its own and I didnt touch anything. It rebooted automatically and I tried to see if IP was updated correctly and I found I could not access IP anymore (by pressing F10 when server starts), I thought I did it wrong and I flashed it again and it was still broken.

I tried with other versions of IP but still no luck.

I could not get a screen shot of the broken IP because it just doesnt work, there is no error message or anything, it just doesnt load up, but I found another issue after the update failure which I can take a screen capture - the Emebedded Diagnose is now also broken and it gives an error message.

I just realised I could not upload an image to the forum, but still hope I can get some help, thanks.

4 REPLIES 4
support_s
System Recommended

Query: Help Needed. Embedded Diagnose and Intelligent Provisioning Broken After Firmware Update

System recommended content:

1. Intelligent Provisioning

 

If the above information is helpful, then please click on "Thumbs Up/Kudo" icon.

 

Thank you for being a HPE community member.


Accept or Kudo

Cali
Honored Contributor

Re: Help Needed. Embedded Diagnose and Intelligent Provisioning Broken After Firmware Upda

Hi,

you can Upload a Photo by using:
Bild 2021-11-29-003.png

Try to make a Photo with your Handy Camera and Upload it.
Try to connect with the iLO Web GUI or iLO Service Port on Front (If there).
Try to boot your Server with the "Service Pack for ProLiant" DVD (USB) and do a complete Firmware Update.

Cali

 


======================
I'm not an HPE employee, so I can be wrong.
AngusHK
Occasional Visitor
Solution

Re: Help Needed. Embedded Diagnose and Intelligent Provisioning Broken After Firmware Upda

I think beucase I am new so the upload image function is blocked to me.

It is an MS server so there is not a Service Port.

However I have fixed it by flasing the iso image with a Windows PC instead of an Mac.

But I think it is not a good thing. If the system doesnt accept a firmware and it should revert the firmware back to the state before the update instead of having a "broken" firmware flased into the ROM.

I can't believe this happens to an HPE server.

Cali
Honored Contributor

Re: Help Needed. Embedded Diagnose and Intelligent Provisioning Broken After Firmware Upda

iLO is a Physical "Diagnostic" Port on the Server with provides a Web GUI, regardless of any OS.

Check this:

https://youtu.be/_rRdEekFgVA

https://youtu.be/vh3XMvQj468

Cali


======================
I'm not an HPE employee, so I can be wrong.