ProLiant Servers (ML,DL,SL)
cancel
Showing results for 
Search instead for 
Did you mean: 

Help - harddisk sas not detected when install windows 2008 r2

no_name
Frequent Advisor

Help - harddisk sas not detected when install windows 2008 r2

Hi there,

Need help please.
We just bought e320e g8, and add 2 harddisk 450gb sas.
I've configured raid 1 (i found the system use p222 as smart raid).

When install windows 2008 r2 enterprise, the windows can't detect the hard disk.

I'm pretty sure already set:
- boot sequence order: cd rom, hdd
- hdd boot controller: (1) P222 raid, (2) p120 raid
On f9 menu.

And on raid menu (by pressing f5), i did:
- configure raid 1.

Kindly please help how to make the harddisk detected by windows installation. Thanks in advance
11 REPLIES
Jimmy Vance
HPE Pro

Re: Help - harddisk sas not detected when install windows 2008 r2

Sounds like the B120i is still cabled to the drive backplane. Make sure the cables from the backplane have been moved from the embedded B120i to the P222 card? The B120i doesn't support SAS drives.

 

 




__________________________________________________
No support by private messages. Please ask the forum!      I work for HPE

If you feel this was helpful please click the KUDOS! thumb below!   
no_name
Frequent Advisor

Re: Help - harddisk sas not detected when install windows 2008 r2

Hi jimmy,
Thanks for reply.
Do i only need to move the cable,or need another step/setting?

I'm not familiar with HP hardware. Usually we bought DL380 which is already preinstalled smart array that support sas. I only need to plug the hard drive and configure the raid as I want.

But on the dl320e (ours is DL320e G8, not dl320e g8 v2), after i configure the raid, boot from cd windows 2008 r2 enterprise, the installlation xd can't detect the hard drive.

Need help. Thanks in advance
Jimmy Vance
HPE Pro

Re: Help - harddisk sas not detected when install windows 2008 r2

Yes, the only thing that needs to be done is move the backplane cable from the port on the system board to the port on the P222. I'm going under the assumption that when the P222 was installed the cable wasn't moved




__________________________________________________
No support by private messages. Please ask the forum!      I work for HPE

If you feel this was helpful please click the KUDOS! thumb below!   
no_name
Frequent Advisor

Re: Help - harddisk sas not detected when install windows 2008 r2

Hi. Ok i'll look then. I'm still outside of the office.
Is there manual instruction related this? Sorry for my basic question.

Thanks
no_name
Frequent Advisor

Re: Help - harddisk sas not detected when install windows 2008 r2

Hi,
I've looked and found that the cable has been attached to the the card.
P222 has been set to ctrl 1 on f9/boot controller order.

Any advice please? Thanks
no_name
Frequent Advisor

Re: Help - harddisk sas not detected when install windows 2008 r2

Hi.
Just wanna give update.
I change sata controller to AHCI (before: smart array b120i).

Then try to install windows. It's works. But is it normal that the fan sound quite loud?

Need advice please. Thanks

When i installed under intelligent provisioning, always show an error. Current intelligent provisioning version is 1.50

I've attached screenshot for the error message

 

 

 

 

 

 

 

no_name
Frequent Advisor

Re: Help - harddisk sas not detected when install windows 2008 r2

Hello there? Anyone help pls?
Thanks
Jimmy Vance
HPE Pro

Re: Help - harddisk sas not detected when install windows 2008 r2

Set the P222 as the boot controller, and also set the array as the boot LUN

 




__________________________________________________
No support by private messages. Please ask the forum!      I work for HPE

If you feel this was helpful please click the KUDOS! thumb below!   
no_name
Frequent Advisor

Re: Help - harddisk sas not detected when install windows 2008 r2

Hi. Thanks for reply.

I've set the p222 as the 1st boot controller.

Just wanna make sure that I'm on the right track, I did:
Set the sata mode as AHCI ( before: p120i...)
Set the 1st boot controller to p220

If I'm on the right track, then how to make sure the raid is working properly?

Thanks in advance.
Jimmy Vance
HPE Pro

Re: Help - harddisk sas not detected when install windows 2008 r2

you shouldn't need to change the mode of the embedded controller, but it won't hurt anything if you set it to AHCI mode.

 

When in HPSSA you should see both controllers (unless the B120i is in AHCI mode), the B120 shouldn't show any disks attached, and the P222 Should show the disks and the raid level of the array you created




__________________________________________________
No support by private messages. Please ask the forum!      I work for HPE

If you feel this was helpful please click the KUDOS! thumb below!   
no_name
Frequent Advisor

Re: Help - harddisk sas not detected when install windows 2008 r2

Hi.thanks for quick reply.

Yes, on the initial display, the system detect both controller and exactly with your describing. So this is normal? I mean this indicate all thing going right on the track?

Thanks.