ProLiant Servers (ML,DL,SL)
cancel
Showing results for 
Search instead for 
Did you mean: 

How to bypass f1 when booting server

Mr Yossu
Occasional Visitor

How to bypass f1 when booting server

Hello,

I have a Proliant DL580 server, which has the well-known issue that it stops when booting requiring someone to press f1 to continue.

I am trying to disable this feature so that the server will just reboot on its own, but can't find out how to do it.

I found another thread that asked the same question (link below), and the poster said...

"The BIOS configuration has to be put into advanced mode by hitting Control-A when it starts"

This is fine, except I can't see how to do this. I tried hitting Control-A when the machine started, but nothing happened. I didn't see any option to enter the BIOS.

When the machine reboots, I first get the memory check, then the four processors initialising. I get a message about hitting f8 to enter the smart array configuration. After that, the smart array controller initialises, and the machine boots into Windows.

I tried going into the smart array configuration, but hitting Control-A there didn't do anything.

So how do I do this? Presumably there is some simple way of getting into the BIOS. Anyone know?

Thanks

Link to the forum thread...
http://forums1.itrc.hp.com/service/forums/questionanswer.do?threadId=1148322&admit=-682735245+1187175868295+28353475

8 REPLIES
~sesh
Esteemed Contributor

Re: How to bypass f1 when booting server

Do you mean you do not see an option F9 to get into the ROM Based Setup Utility (RBSU) before Windows Starts Loading?

I am sure that this option is not something that can disabled or enabled. It is always there.

If you can press F9 and get into the RBSU, set "Prompt F1" to "Disabled" (this can normally be found under "Server Availability").

Mr Yossu
Occasional Visitor

Re: How to bypass f1 when booting server

Hello,

Thanks for the reply. No I don't see an option to press f9 to enter the RBSU. According to the thread that I linked, RBSU wasn't available on first generation DLs, which I think is what I have.

That thread said that you could disable the f1 prompt from the advanced options you get by hitting Control-A when you went into the BIOS, but I can't see a way of getting into the BIOS in the first place.

Any ideas? Thanks
KarloChacon
Honored Contributor

Re: How to bypass f1 when booting server

Hi

to get into BIOS press F2 (I think you have phoenix bios)

after that check this, page 13 (or 9 according to the document)
- Boot options
-Post Errors
- and disable

http://www.phoenix.com/NR/rdonlyres/5AF5C50D-9E06-4298-9E58-E52BFFCC8D7D/0/userman.pdf

i hope this can help you

regards
Didn't your momma teach you to say thanks!
Mr Yossu
Occasional Visitor

Re: How to bypass f1 when booting server

Hello,

Thanks for the reply. Unfortunately, it didn't help.

Pressing f2 didn't do anything, and looking at the screen during the initial boot, I don't think I have a phoenix BIOS. The first line on the screen during boot up says...

Compaq System BIOS - P20 (12/17/2002)

Which implies it's a Compaq BIOS.

Any other ideas how I can get into the BIOS? Thanks again
KarloChacon
Honored Contributor

Re: How to bypass f1 when booting server

Mr Yossu
Occasional Visitor

Re: How to bypass f1 when booting server

Hello,

The first of those links is the one that I quoted in my very first post. I still don't know how to get into the BIOS, so the control-A for advanced doesn't help me.

As for the second one, I have a smart array set up CD version 5.4, which I have tried using, but although you can set some BIOS things there, I can't see any setting where you can disable the f1 prompt.

Do you know how to get at it?

Thanks
voodookid
Occasional Contributor

Re: How to bypass f1 when booting server

F10 on that BIOS will get you in the System Utilities Partition. Press is after something about looking for SCSI devices and right before windows starts its boot process. There will be a blinking cursor in the upper left corner usually. It is a bit tricky to get right, I usually hit F10 over and over after it searches for SCSI devices. Once you get into SCU (System Configuration Utilities) hit any key and then CTL-A. Configure hardware. I believe it is option 3 that you need to get into the board settings or something like that. Scroll down and there will be something about F1 stop being enabled. Just highlight it and then disable it. Save you settings, restart the machine and it won't hang on boot.
The F1 to continue is usually a sign that something is wrong or not configured correctly. On these machines there is the no built-in utilities that will change the settings of the NVRAM. you must install that partition when setting the machine up. Hopefully whoever set that machine up before you has.
vockens
Occasional Visitor

Re: How to bypass f1 when booting server

Hi am in the system ulities and am having a hard time locating the f1 prompt ,help