ProLiant Servers (ML,DL,SL)
cancel
Showing results for 
Search instead for 
Did you mean: 

How to enable Embedded NICs on Proliant dl380 G5

Kevin Keller_2
Frequent Advisor

How to enable Embedded NICs on Proliant dl380 G5

I have a Proliant dl380 G5. In the System ROM the embedded NICS are set for ISCSI. How can I switch back from ISCSI? Thank you in advance.

 

-Kevin

15 REPLIES
scharchouf
Trusted Contributor

Re: How to enable Embedded NICs on Proliant dl380 G5

Under System Options you can find Embedded NICs

 

Options:

• Network Boot

• Disabled

 

I advice You to check Standard Boot Order (IPL)

I work for HP
A quick resolution to technical issues for your HP Enterprise products is just a click away HP Support Center Knowledge-base
See Self Help Post for more details

Kevin Keller_2
Frequent Advisor

Re: How to enable Embedded NICs on Proliant dl380 G5

I tried that and no luck. The iscsi still show the mac addresses and the Nic aren't showing a mac address and say "disabled".

 

scharchouf
Trusted Contributor

Re: How to enable Embedded NICs on Proliant dl380 G5

can you post here a screenshoot of this issue please?

I work for HP
A quick resolution to technical issues for your HP Enterprise products is just a click away HP Support Center Knowledge-base
See Self Help Post for more details

Kevin Keller_2
Frequent Advisor

Re: How to enable Embedded NICs on Proliant dl380 G5

There you go.

scharchouf
Trusted Contributor

Re: How to enable Embedded NICs on Proliant dl380 G5

so the First action Plan is :

 

Use this lin to choose the appropriate OS and Update BIOS & iLO :

 

http://h20565.www2.hp.com/portal/site/hpsc/public/psi/swdHome/?cc=us&cc=us&lang=en&lang=en&sp4ts.oid=3288134&ac.admitted=1396117058664.876444892.492883150

 

 

I work for HP
A quick resolution to technical issues for your HP Enterprise products is just a click away HP Support Center Knowledge-base
See Self Help Post for more details

Kevin Keller_2
Frequent Advisor

Re: How to enable Embedded NICs on Proliant dl380 G5

Done and Done! Both were already at that level, but I reinstalled it anyway. No change after the reinstall and reboot.

Jimmy Vance
HPE Pro

Re: How to enable Embedded NICs on Proliant dl380 G5

I tried various settings on a DL380 G5 here. I cannot get it in the same mode your system is showing. If I disable a NIC, it also shows the iSCSI portion disabled.  My suggestion is to set the maintenance switch 6 on, and reset the ROM to factory default.




__________________________________________________
No support by private messages. Please ask the forum!      I work for HPE

If you feel this was helpful please click the KUDOS! thumb below!   
Kevin Keller_2
Frequent Advisor

Re: How to enable Embedded NICs on Proliant dl380 G5

I did that and even pulled the battery. It keeps coming back with the NICs disabled and ISCSI showing the MAC address.

Jimmy Vance
HPE Pro

Re: How to enable Embedded NICs on Proliant dl380 G5

I'm pretty sure the iSCSI MAC addresses are always displayed with the multi-function NICs. The Ethernet MAC and the iSCSI MAC are different values. When I disabled a NIC port in RBSU, the iLO listed the NIC as disabled, the corresponding iSCSI port was listed disabled as well. 

 

If resetting the System ROM back to defaults doesn't fix the issue, maybe there is an issue with system board itself




__________________________________________________
No support by private messages. Please ask the forum!      I work for HPE

If you feel this was helpful please click the KUDOS! thumb below!   
scharchouf
Trusted Contributor

Re: How to enable Embedded NICs on Proliant dl380 G5

So try to do do an Clear NVRAM

 

If the issue persist, replace MOBO

I work for HP
A quick resolution to technical issues for your HP Enterprise products is just a click away HP Support Center Knowledge-base
See Self Help Post for more details

waaronb
Respected Contributor

Re: How to enable Embedded NICs on Proliant dl380 G5

I'm checking on a spare DL380 G5...

1) Hit F10 at boot and go into the setup utility

2) select "System Options" from the ROM based setup

3) select "Embedded NICs"

4) Choose "NIC 1" or "NIC 2" boot options

4a) you may get a warning about switching between pxe/iscsi

5) See what option it's currently set to: "iSCSI Boot", "PXE Boot" or "Disabled"

 

Set one or both to PXE boot and restart the machine and see if that makes a difference.

 

I've never actually used the built in NICs for iSCSI so I'm a little curious myself to see how that goes.

Kevin Keller_2
Frequent Advisor

Re: How to enable Embedded NICs on Proliant dl380 G5

Already tried that. No luck. The ports are still stuck at the ISCSI settings.

scharchouf
Trusted Contributor

Re: How to enable Embedded NICs on Proliant dl380 G5

So, replace MotherBoard

I work for HP
A quick resolution to technical issues for your HP Enterprise products is just a click away HP Support Center Knowledge-base
See Self Help Post for more details

Jimmy Vance
HPE Pro

Re: How to enable Embedded NICs on Proliant dl380 G5


Kevin Keller_2 wrote:

Already tried that. No luck. The ports are still stuck at the ISCSI settings.


They aren't really "stuck at the iSCIS settings". Even on a system using both NICs only for Ethernet network traffic, the iSCSI MAC addresses show up in RBSU and iLO NIC system information.




__________________________________________________
No support by private messages. Please ask the forum!      I work for HPE

If you feel this was helpful please click the KUDOS! thumb below!   
Jimmy Vance
HPE Pro

Re: How to enable Embedded NICs on Proliant dl380 G5

I had not looked at this other thread until this morning.  One of the messages says the NICs show as disabled. Did you update teh NIC firmware right before this problem appeared?

 

 

http://h30499.www3.hp.com/t5/ProLiant-Servers-ML-DL-SL/HP-Proliant-DL380-G5-NIC-s-not-found-after-firmware-update/m-p/6433352#M142028

 

 




__________________________________________________
No support by private messages. Please ask the forum!      I work for HPE

If you feel this was helpful please click the KUDOS! thumb below!