ProLiant Servers (ML,DL,SL)
cancel
Showing results for 
Search instead for 
Did you mean: 

I'm trying to add a 2Tb sas drive to my ML310 G5 with P400 256mb raid controller

 
PhilPayne
Occasional Advisor

I'm trying to add a 2Tb sas drive to my ML310 G5 with P400 256mb raid controller

Hi, I'm trying to install the following 2tb hard drive in my old ML310 G5 server to help upgrade it and get more life from it.

 

It's the HP MB2000FAMYV 2TB 7.2K SAS 3.5" drive which has an additional Seagate ref ST32000444SS.

 

I've installed the P400 card and changed the cable from the HD cage to the one that came with the P400 card. The card is recognized no problem when the machine boots but the drive is not. The bios shows the prompt initializing for several seconds and then the hard drive green led flashes for a sec and then an amber LED stays permanently on and the Bios reports no hard drive found and moves on.

 

According to the specs for the P400 card this hard drive is supported but the quickspecs for the ML310 G5 doesn't list the drive.

 

What could be the problem? The drive was taken from a working server, decommissioned, so should be good.

 

Any help would be much appreciated.

 

Regards

 

Phil

12 REPLIES
PhilPayne
Occasional Advisor

Re: I'm trying to add a 2Tb sas drive to my ML310 G5 with P400 256mb raid controller

Just to add one further thing the P400 card has been upgraded to the latest firmware.

Thanks.
Johan Guldmyr
Honored Contributor

Re: I'm trying to add a 2Tb sas drive to my ML310 G5 with P400 256mb raid controller

Hi!

 

" Bios reports no hard drive found and moves on."

 

If you go into ORCA or boot the server on SPP can you see the disk to add it to an array and create a logical volume?

PhilPayne
Occasional Advisor

Re: I'm trying to add a 2Tb sas drive to my ML310 G5 with P400 256mb raid controller

Hi Johan, I don't understand what is ORCA or SPP?

Thanks for your reply

Phil.
Johan Guldmyr
Honored Contributor

Re: I'm trying to add a 2Tb sas drive to my ML310 G5 with P400 256mb raid controller

SPP: www.hp.com/go/spp/download

 

Is a bootable ISO that you can burn to a DVD or add on a USB stick.

Within ACU (HP Array Configuration Utility) inside SPP you can take the disk you've added and add into a disk array (or I should say, you create an array and then you add disks to it).

Out of the array you can create a logical volume (or several).

This logical volume will be visible as a disk to your OS.

 

ORCA is a similar tool to ACU - but you can enter it by pressing F8(could be another function button) at the right time during POST, there should be a message indicating when it's appropriate to press it.

PhilPayne
Occasional Advisor

Re: I'm trying to add a 2Tb sas drive to my ML310 G5 with P400 256mb raid controller

Hi Johan, I can try the SPP, however there is no prompt to press F8 as the controller can't see and initialise the disk. I did get the F8 prompt when I placed a 250gb sata drive in one of the bays as the controller saw the Sata disc. I think it's unlikely SPP will work as this would rely on the controller seeing the disc which it doesn't.

I read all the literature I could find regarding changing from sata to SAS on this server however the details are very sparse. there are some jumpers on the sas/sata backplane that the cable connects to from the P400 card however I don't know what these do as I can't find any information relating to them.

Thanks again for your reply.

Phil.
Johan Guldmyr
Honored Contributor

Re: I'm trying to add a 2Tb sas drive to my ML310 G5 with P400 256mb raid controller

I agree. SPP won't help much, unless you need to upgrade firmware on the System BIOS.

 

Just to clarify: A 250GB SATA disks is found in a slot where the 2TB disk is not?

 

Which HP product / spare part number is it on the disk you got?

PhilPayne
Occasional Advisor

Re: I'm trying to add a 2Tb sas drive to my ML310 G5 with P400 256mb raid controller

There are several, 507613-002, a sticker added with 507616R-B21, and another with 507618-003. The drive has model MB2000FAMYV number on it. It's basically a re-badged Seagate drive as it has the ref ST32000444SS on the label.

Thanks.
PhilPayne
Occasional Advisor

Re: I'm trying to add a 2Tb sas drive to my ML310 G5 with P400 256mb raid controller

Could the problem be the cable that I am using to connect between the sas controller and the backplane of the hard drive cage? The ML310 quickspec says use a 460310-b21 but the cable I got with the P400 card is a 361316-011. they both appear to be the same with 2con x4 plane SFF 8484 connectors at each end. What could possibly be different between them?

Thanks

Phil.
Johan Guldmyr
Honored Contributor

Re: I'm trying to add a 2Tb sas drive to my ML310 G5 with P400 256mb raid controller

Don't know the difference but if the quickspecs says that cable is required then.

 

http://h30499.www3.hp.com/t5/ProLiant-Servers-ML-DL-SL/PROLIANT-ML310-G5P-amp-HP-Smart-Array-P400-Controller/td-p/5355851#.UskQw5AW2Kl

 

Is a topic where they got it working with the cable from the quickspecs.

Jimmy Vance
HPE Pro

Re: I'm trying to add a 2Tb sas drive to my ML310 G5 with P400 256mb raid controller

If the cables look the same, it could be the 460310-b21 is the option part number used to originally order the cable, and the other number is the spare number that is used to order a replacment.

 

If the SATA drive is recognised, the cable is probably OK, as there isn't a different cable or a controller setting to switch between SATA and SAS.  The only limitiation is that you cannot mix SATA / SAS drives in the same array, You can create an array with SAS, and an additional array with SATA on the same controller.

 

The F8 prompt for ORCA should appear even if no drives are connected

 

Were you putting the disks in the same slot, if not maybe a defective drive bay??

 

Are you sure the SAS disk is good?

 

 

 

 

 




__________________________________________________
No support by private messages. Please ask the forum!      I work for HPE

If you feel this was helpful please click the KUDOS! thumb below!   
PhilPayne
Occasional Advisor

Re: I'm trying to add a 2Tb sas drive to my ML310 G5 with P400 256mb raid controller

Hi Jimmy, to answer all your questions, yes I have tried the SAS drive in the same slot and in other slots to that used by the SATA drive. The SATA drive, a 250gb one, is seen by the P400 controller and the F8 prompt appears in the boot up bios when the SATA drive is in the slot but doesn't appear when the SAS drive is in the slot. The message during bootup is that the controller is trying to initialise the drive but that this fails in the case of the SAS drive and the message reports no drives found.
The SAS drive is second hand bought recently and the person I bought it from says that it was working in their server prior to the motherboard failing.
The drive lights up the two led's at power on green and blue and just prior to the drive failing initialisation, the green led comes on but then this goes out and an amber one is permanently on.

I was about to try and purchase the cable recommended by HP for SAS drives on the ML310 G5 server but is this going to make a difference if the P400 controller can see the sata drive when it's installed?

Thanks Phil.

Jimmy Vance
HPE Pro

Re: I'm trying to add a 2Tb sas drive to my ML310 G5 with P400 256mb raid controller

I don't think it is a cable issue, I'd lean towards a bad drive. Unless a drive has been put in an array, the controller will report zero drives during POST

 

The drive light going amber and staying that way also indicates a defective disk




__________________________________________________
No support by private messages. Please ask the forum!      I work for HPE

If you feel this was helpful please click the KUDOS! thumb below!