ProLiant Servers (ML,DL,SL)
cancel
Showing results for 
Search instead for 
Did you mean: 

IDE salve not detected

jordi garcia_1
Occasional Advisor

IDE salve not detected

Hello,

In my ML150 G2 i have changed the FDD for a IDE hard disk.

I connect de new hd to the IDE cable that uses the CDROM.

This is what I get:
hd master + CD slave = CD not detected
hd slave + CD master = hd not detected

I have changed the cable for a new one and the result is the same.

Why my BIOS is not detecting anything conected to the slave conector?

I am sure the pin is set up correctly for the drives to be in position of master, slave or cable select. Never work.

BTW, the FDD cable is disconected from the mobo as the fdd unit is not used anymore.
4 REPLIES
Matti_Kurkela
Honored Contributor

Re: IDE salve not detected

Several possibilities:

- If the slave type is set to "None" (or "Disabled") in BIOS, it means the BIOS won't even try to detect it and assumes you don't want to use it. Set it to "Auto" (or something like it) instead and try again.

- Some IDE hardware used to have a different set of jumper pins, with a set of three choices: Master (alone), Master with Slave Present, and Slave.

- What kind of IDE cable you're using now? Is it a 40-pin or 80-pin wire?

- Do you see a small hole anywhere in the ribbon cable, interrupting exactly 1 wire? That would indicate a "cable select" feature in certain IDE cable types. If the hole exists, it should be between the "master" and "slave" connectors, not between the system board connector and the drives.

- If each of the connectors of the IDE cable has a different colour, then it should be connected like this:
* blue connector (at one end of the cable) to the motherboard
* black connector (at the other end) to the master drive
* gray connector (in the middle of the cable) to the slave drive

In this case, the connector colours and the jumper selections *must* match: don't connect the black connector to a drive jumpered as slave.

MK
MK
jordi garcia_1
Occasional Advisor

Re: IDE salve not detected

[quote]
- If the slave type is set to "None" (or "Disabled") in BIOS, it means the BIOS won't even try to detect it and assumes you don't want to use it. Set it to "Auto" (or something like it) instead and try again.
[\quote]

In the BIOS there is only control for:
IDE Channel 0 Master:

I can not find the option for 'Channel 0 Slave' which should be right below the Master control.


[QUOTE]
- Some IDE hardware used to have a different set of jumper pins, with a set of three choices: Master (alone), Master with Slave Present, and Slave.
[\QUOTE]

Double checked and not solution.

[QUOTE]
- What kind of IDE cable you're using now? Is it a 40-pin or 80-pin wire?
[\QUOTE]

I have tryed with both tipes.

[QUOTE]
- Do you see a small hole anywhere in the ribbon cable, interrupting exactly 1 wire? That would indicate a "cable select" feature in certain IDE cable types. If the hole exists, it should be between the "master" and "slave" connectors, not between the system board connector and the drives.
[\QUOTE]

No hole in the cables.

[QUOTE]
- If each of the connectors of the IDE cable has a different colour, then it should be connected like this:
* blue connector (at one end of the cable) to the motherboard
* black connector (at the other end) to the master drive
* gray connector (in the middle of the cable) to the slave drive

In this case, the connector colours and the jumper selections *must* match: don't connect the black connector to a drive jumpered as slave.
[\QUOTE]

Double checked and not solution.

Is it posible that the mobo for the Proliant ML150 G2 doesn't support slave drive on the IDE channel? It is strange that I don't see anything related to Channel 0 Slave on the BIOS. At least I would espect something like 'Channel 0 Slave Disable'. This makes me wonder if there is not support for slave on this BIOS.

If this is the case, is it posible to connect the cdRom tho the FDD plug with some adaptor? (I hope this is not a stupid question, my apologies)

Thanks.
Trygve Henriksen
Respected Contributor

Re: IDE salve not detected

I may be mistaken, but...

I believe the IDE controller in that server is there ONLY for CD-ROMs, and therefore only supports one device.
All HDDs are supposed to be on an SATA or Ultra-SCSI controller.

So you may need to either find a different type of drive, or an extra controller if you want more storage.

Or you could get an USB-based CD-ROM.
jordi garcia_1
Occasional Advisor

Re: IDE salve not detected

No sugestion?