ProLiant Servers (ML,DL,SL)
cancel
Showing results for 
Search instead for 
Did you mean: 

ILO Virtual Drive and UDF DVD

Judoboy
Visitor

ILO Virtual Drive and UDF DVD

Hi,

 

I want to install a Proliant server with a DVDROM through the ILO Virtual Drives.

 

I 'mount' my ISO image file in the ILO Integrated remote Console (Version 1.2.3.1405).

I'm able to BOOT on this virtual DVD (WinPe is loaded and executed).

 

But when the system try to access the DVD to install the Windows image, there is an error 'Source not found'.

 

If I use a console, I can browse the Virtual DVD ... and there is only one README.TXT file containing :

"This disc contains a UDF file system and requires an operating system that supports the ISO-13346 UDF file system specification".

 

For sure, if I burn my DVD, there is no issue, it's working.

 

Seems there is some problem with the ILO Virtual Drive and WinPe.

 

Can you help me to solve this critical problem ?

 

Thanks,

 

Regards,

6 REPLIES
Dr_Ray
Visitor

Re: ILO Virtual Drive and UDF DVD

Hi,

 

I have seen this a few times. My DVDs are made with Microsoft oscdimg and has both the ISO and UDF formats, so when the UDF is not recognised I get truncated filenames as it uses ISO with 8.3.

 

What I have found fixes it it to do a full BIOS system erase/restore settings from the  "System Default Options" BIOS section. Sometimes copying the ISO to a new location and remounting it will work.

 

Ray.

 

 

 

Judoboy
Visitor

Re: ILO Virtual Drive and UDF DVD

Hi,

 

Thanks fot the tips ... but it doesn't work.

I have tested on 2 servers, still the same issue.

 

 

Dr_Ray
Visitor

Re: ILO Virtual Drive and UDF DVD

I've done some more tests and all of my failures are with ILO firmware 1.32. If I downgrade to 1.30 it works ok and mounts as UDF.

 

Can you confirm your firmware version??

 

Ray.

Judoboy
Visitor

Re: ILO Virtual Drive and UDF DVD

Hi,

 

Thanks for your tests ...and I confirm, I have the latest version.

       iLO  Nov 05 2013 1.32 

 

It seems that there is a bug in this version.

 

Do you know how to escalate to HP ?

 

Thanks,

Dr_Ray
Visitor

Re: ILO Virtual Drive and UDF DVD

I think HP are already aware. This post

 

http://h30499.www3.hp.com/t5/ProLiant-Servers-ML-DL-SL/ILO4-Firmware-1-32-and-Windows-OS-Install-Errors/td-p/6339925

 

has the following:

 

 

Re: ILO4 Firmware 1.32 and Windows OS Install Errors[ New ]
Friday
      - last edited
Friday

I just tried booting from Windows 2012 R2 ISO and I saw the same issue.

 

I know what is going on. It is related to code we recently added to iLO2, iLO3 and iLO4 firmware to workaround a problem with SLES11 where mounting virtual media would fail after SP3 is installed. We are going to have to remove this workaround in the next release as it breaks 2012 R2.

 

For the mean time, please use iLO4 v1.30 to deploy the OS then you can upgrade iLO4 back to a later version.

 

Sorry for the inconvenience.

Judoboy
Visitor

Re: ILO Virtual Drive and UDF DVD

Thanks,

 

I will then wait for the update.