ProLiant Servers (ML,DL,SL)
cancel
Showing results for 
Search instead for 
Did you mean: 

ILO3 Firmware update crashed server

feizex
Occasional Visitor

ILO3 Firmware update crashed server

Hi Guys,

 

I thought I'd share this as I found it bizzare that it could happen.

 

I was updating firmware on ILO3 on DL380 Gen7. The Firmware update stalled at 1%. After about 30 minutes I tried resetting the ILO, and it did not reset, but update jumped to 9% and stayed there.

 

After about an hour the server crashed. It's running Esxi 5.1. All the VMs stopped responding and there was a purple crash screen on server console.

 

I don't know how an ILO update through the ILO web interface could crash the server - yet that is what happened.

 

I have since found that I needed to load an intermediate ILO FW version before loading the latest. Server was on 1.26 and I tried jumping to 1.61. That is the one that stalled and crashed the server.

 

After crash I powered off server using power button. It then went into a strange cycle of powering itself on for a few seconds (green lights) and then off (orange lights). All the while the UID Indicator light was flashing blue - indicating that ILO firmware was still "flashing".

 

I had to pull the server power cords for a few seconds till the lights went off and then plug them in. Server started up OK.

 

I flashed ILO to 1.28 and then to 1.61 without issue. I kept the VMs off while doing this incase there was a repeat. Thankfully all went OK. The VMs came up OK after too.

 

Just a warning about what can happen if flash goes wrong!

 

Regards,

Feizex.