ProLiant Servers (ML,DL,SL)

ILO4 on ML30 Gen9 won't receive DHCP address

Occasional Contributor

ILO4 on ML30 Gen9 won't receive DHCP address


My server's ILO isn't getting a DHCP address on whichever interface is connected to my LAN.

I have an ML30 Gen9 set up where NIC port 2 is connected to my WAN gateway. I run pfSense in a Hyper-V VM as a firewall and router. NIC port 1 is connected to the LAN. When I use the Online Configuration Utility, I have 'Shared Network Port' set to 'Enable LOM', and the 'SNP Port' is port 1. There is no VLAN.

I've tried switching the ports around so that the WAN is connected to port 1, and LAN to port 2, but what keeps happening is that a DHCP address is only given to ILO when the SNP port is set to the port connected to the WAN gateway, and the WAN gateway's DHCP server gives a local address of 192.168.2.x. On the port connected to the LAN, the utility reports an address of ''. My LAN's DHCP server is running on a Windows Server 2016 domain controller, and it hands out addresses in the 192.168.1.x range.

I recently changed the LAN network to use private IP addresses. Previously, the Windows DHCP server was giving IP addresses in the 10.0.0.x range. ILO did in fact receive a proper IP address under this scenario, but in this case, both NIC ports were connected to the LAN.

Any ideas on what the problem might be?