ProLiant Servers (ML,DL,SL)
cancel
Showing results for 
Search instead for 
Did you mean: 

IP address information not set suring unattended installation

Chris_474
Occasional Visitor

IP address information not set suring unattended installation

I have a DL380G3 that I am attempting to put a unattended installation on.

I have specified a OEMPnPDriversPath directory on the CD that I am using. In this directory I have added the updated driver for the NC7781 NIC that is on board on the Dl380G3.

The problem is that when my unattend.txt file includes the IP information for the NICS, not all of the information is applied.

In this case the default gateway, DNS Server and WINS server addresses are applied but the IP Address and Subnet mask are obtained from the DHCP server. The adapters also pick up the correct name for the NIC as specified in the Unattend.txt.

Has anyone seen this problem before or know the reason why this is happening?

I have included part of the unattend.txt file below.

Cheers,

[NetAdapters]
Adapter1=params.Adapter1
Adapter2=params.Adapter2

[params.Adapter1]
ConnectionName="CPQLAN-1"
INFID=*
PciBusNumber="2"
PciDeviceNumber="1"
PciFunctionNumber="0"

[params.Adapter2]
ConnectionName="CPQLAN-2"
INFID=*
PciBusNumber="2"
PciDeviceNumber="2"
PciFunctionNumber="0"

[NetClients]
MS_MSClient=params.MS_MSClient

[NetServices]
MS_SERVER=params.MS_SERVER

[NetProtocols]
MS_TCPIP=params.MS_TCPIP

[params.MS_SERVER]
Optimization = MaxThroughputForNetworkApps

[params.MS_TCPIP]
DNS=No
UseDomainNameDevolution=No
EnableLMHosts=Yes
AdapterSections=params.MS_TCPIP.Adapter1,params.MS_TCPIP.Adapter2

[params.MS_TCPIP.Adapter1]
SpecificTo = Adapter1
DHCP=No
IPAddress="1.1.1.1"
SubnetMask="2.2.2.2"
DefaultGateway="3.3.3.3"
DNSServerSearchOrder="6.6.6.6","7.7.7.7"
WINS=Yes
WinsServerList="4.4.4.4","5.5.5.5"
NetBIOSOptions=1

[params.MS_TCPIP.Adapter2]
SpecificTo = Adapter2
DHCP=No
IPAddress="8.8.8.8"
SubnetMask="9.9.9.9"
DefaultGateway="10.10.10.10"
DNSServerSearchOrder="6.6.6.6","7.7.7.7"
WINS=Yes
WinsServerList="11.11.11.11","12.12.12.12"
NetBIOSOptions=1
2 REPLIES
Stephen Grimmer
Trusted Contributor

Re: IP address information not set suring unattended installation

Static IP Address Is Not Retained During Windows 2000 Unattended Installation (262688)


Interesting reading not sure it applies...

Might want to try newer drivers there were some related issues with nt4 and newer drivers solved it...


Chris_474
Occasional Visitor

Re: IP address information not set suring unattended installation

Thanks for the reply stephen.

Had seen the KB article before and it doesnt make any difference.

I have the most upto date driver from Hp/Compaq (q57) but am now considering using the B57 driver from broadcom.