ProLiant Servers (ML,DL,SL)
cancel
Showing results for 
Search instead for 
Did you mean: 

Ignore FC/NIC link down status via CLI

 
LookHereSonny
Occasional Contributor

Ignore FC/NIC link down status via CLI

I have over 100 ProLiant Gen8/Gen9 servers with FlexFabric NICs set to FCoE personality mode. Many of the servers don’t have LUNs assigned to the FCoE adapter and they are not zoned on my FCoE switches. These servers all show up with warning status in System Management Homepage, Insight Manager, SCOM, etc. because the Fibre Channel HBA status shows as "Link Down". There is an option in SMH under Fibre Channel to "Ignore Status" which resolves this problem and everything shows green despite the fact that the FC HBA has no link. How do I programmatically (or via CLI) set this 100s of servers short of setting them to iSCSI personality?

I've tried poking around the HPQ WBEM WMI classes in Windows but can’t find the class that controls this setting. I assume the method would be similar to disabling unused NIC link status as well?