HPE Community read-only access December 15, 2018
This is a maintenance upgrade. You will be able to read articles and posts, but not post or reply.
Hours:
Dec 15, 4:00 am to 10:00 am UTC
Dec 14, 10:00 pm CST to Dec 15, 4:00 am CST
Dec 14, 8:00 pm PST to Dec 15, 2:00 am PST
ProLiant Servers (ML,DL,SL)
cancel
Showing results for 
Search instead for 
Did you mean: 

Installing Linux on BL20p G2

 
Pollux_2
Occasional Contributor

Installing Linux on BL20p G2

Hi there,

I'm having issues installing Linux (SuSE10, Fedora 9, Ubuntu 8 & CentOS 5.2). They all fail, and I suspect it's because of the Storage drivers.

The ones using anaconda installer give me an anaconda error saying /bin/sh could not be executed, input/output error, and block size incorrect.

The ones not using anaconda just give me a blank screen forever.


These errors occur after selecting language, keyboard and installation source options of installation (vmlinuz/kernel) load successfully.

I cannot use SmartStart (7.20) because it freezes after it loads (doesn't let me click which language, images cannot be loaded and buttons cannot be clicked but I can move the mouse).


I went to the RAID config menu and deleted all logical drives, and tried again. No luck.

iLO firmware is old (1.89) but i doubt it will do anything by updating it to the curren release (1.92).

I'm currently downloading SmartStart 8.15 and see if that works.


Any other ideas I should be thinking of?

Thanks in advance,

D.
2 REPLIES
David Claypool
Honored Contributor

Re: Installing Linux on BL20p G2

SmartStart doesn't provide an 'assisted installation' for Linux so that won't make any difference. As you know, SmartStart is a Linux boot itself, so I suspect that the freeze and the blank screen forever are two sides of the same coin. Curious to see if SS 8.15 that you are download behaves any differently. However, this really sounds like a hardware problem of some sort.
Pollux_2
Occasional Contributor

Re: Installing Linux on BL20p G2

Thanks for the reply!

Always thought SmartStart was a way for you to install an OS powered by HP's driver support (New network guy here :).

Anyways, I tried SmartStart 8.15 with the same result. I decided to update Java (from 1.5 to java 1.6 update 14) since remote console runs on Java, but no luck either. Then I decided to downgrade to 1.4 since it's got better support for older java apps (Haven't tried running smartstart again yet).

If it doesn't work I'll just find a different non-blade server to stick linux into and hook it up to my kvm.

thanks again!