ProLiant Servers (ML,DL,SL)
cancel
Showing results for 
Search instead for 
Did you mean: 

Issue with Proliant DL580 G7 and Emulex elxnet driver

AnirbanIXIA
Occasional Visitor

Issue with Proliant DL580 G7 and Emulex elxnet driver

I have Proliant DL580 G7 with the latest image for HP Proliant for ESX5.5 as below:

(Updated) HP-ESXi-5.5.0-Update2-iso-5.76.36
   Name: (Updated) HP-ESXi-5.5.0-Update2-iso-5.76.36

 

I have emulex Adapters with driver as below:

elxnet 10.2.298.5-1OEM.550.0.0.1331820

 

In the vmkernel log I see below messages for this devices : vmnic7

 

 cpu47:33706)PCI: 115: Device 0x7e5741096dfaeddc is not an PCI vmkDevice

 

Also when I run ethtool for vmnic7 it gives below error but for other adapters it works ok as below:

~ # ethtool vmnic5
Settings for vmnic5:
        Supported ports: [ FIBRE ]
        Supported link modes:
        Supports auto-negotiation: No
        Advertised link modes:  Not reported
        Advertised auto-negotiation: No
        Speed: Unknown! (65535)
        Duplex: Unknown! (255)
        Port: Unknown! (255)
        PHYAD: 0
        Transceiver: external
        Auto-negotiation: off
        Supports Wake-on: d
        Wake-on: d
        Current message level: 0x00000007 (7)
        Link detected: no
~ # ethtool vmnic7
Can not get control fd: No such file or directory

 

Here is the output of the nic list

 

~ # esxcli network nic list
Name    PCI Device     Driver  Link  Speed  Duplex  MAC Address         MTU  Description
------  -------------  ------  ----  -----  ------  -----------------  ----  --------------------------------------------------------------------------
vmnic0  0000:004:00.0  nx_nic  Up     1000  Full    ac:16:2d:a3:6c:d8  1500  NetXen HP NC375i Integrated Quad Port Multifunction Gigabit Server Adapter
vmnic1  0000:004:00.1  nx_nic  Down      0  Full    ac:16:2d:a3:6c:d9  1500  NetXen HP NC375i Integrated Quad Port Multifunction Gigabit Server Adapter
vmnic2  0000:004:00.2  nx_nic  Down      0  Full    ac:16:2d:a3:6c:da  1500  NetXen HP NC375i Integrated Quad Port Multifunction Gigabit Server Adapter
vmnic3  0000:004:00.3  nx_nic  Down      0  Full    ac:16:2d:a3:6c:db  1500  NetXen HP NC375i Integrated Quad Port Multifunction Gigabit Server Adapter
vmnic4  0000:008:00.0  ixgbe   Down      0  Half    90:e2:ba:2d:8c:54  1500  Intel Corporation 82599EB 10-Gigabit SFI/SFP+ Network Connection
vmnic5  0000:008:00.1  ixgbe   Down      0  Half    90:e2:ba:2d:8c:55  1500  Intel Corporation 82599EB 10-Gigabit SFI/SFP+ Network Connection
vmnic6  0000:00e:00.0  ixgbe   Down      0  Half    90:e2:ba:45:d6:66  1600  Intel Corporation 82599EB 10-Gigabit SFI/SFP+ Network Connection
vmnic7  0000:005:00.0  elxnet  Up    10000  Full    d4:c9:ef:76:03:e8  1500  Emulex Corporation HP NC552SFP Dual Port 10GbE Server Adapter
vmnic8  0000:005:00.1  elxnet  Down      0  Half    d4:c9:ef:76:03:ec  1500  Emulex Corporation HP NC552SFP Dual Port 10GbE Server Adapter

 

When I chnage the driver to be2net it works fine so I guess it's an issue with the elxnet driver. For some other chnages I need to elxnet driver, so is there any solutin or workaround available for the above problem?

 

Thanks

1 REPLY
Suman_1978
HPE Pro

Re: Issue with Proliant DL580 G7 and Emulex elxnet driver

Hi,

 

A similar issue is discussed here.

 

Search for NC552SFP in this pdf file.

http://downloads.linux.hp.com/SDR/repo/vibsdepot/hpq/recipes/HP-VMware-Recipe.pdf

 

In this case we have to wait till a new driver is released which may fix your issue.

 

 

Thank You!
I am a HP employee.

Useful Links for ProLiant Servers