ProLiant Servers (ML,DL,SL)
cancel
Showing results for 
Search instead for 
Did you mean: 

Issue with upgrading firmware with P410i and P410.

scohesc99
Occasional Collector

Issue with upgrading firmware with P410i and P410.

Hi,

I'm relatively new to Servers in general, so please excuse me if I miss out information, or can't 100% clarify things.

I've recently gotten ahold of a DL380 G7, with accompanying 2017.04 HP Service Pack ISO on a USB stick (yes, I MD5 checksummed it and it matched with what HP's site had)

The server had an integrated HP P410i controller on it, which was having issues. Intermittently, while booting, the P410i would error out, with the error of "Slot 0 HP Smart Array P410i Controller. 1783-Slot 0 Drive Array Controller Failure!, [Command Failure (cmd=11h, err=020h)]."

I figured that maybe it could have been an issue with firmware, as the person I got it off of mentioned they never updated the firmware but had the ISO. I booted up the Service Pack off of a USB stick (created using the HP service pack USB utility), and ran it in automatic mode. Turns out I can't upload images here (I guess it's an anti-spam thing) so I've gone ahead and uploaded them to imgur. Hopefully HP will let me post them here.

https://imgur.com/a/adOFo

It's as if the card doesn't even exist to the firmware updater, but the BIOS of the server is detecting it.

 

I ended up buying a used P410 controller card, and installed it into the server. It worked fine for a few days, but me being stupid decided to try and update the firmware on it again. This time around, the HP Service pack said it had updated the card, and required a reboot to complete the firmware installation. So I clicked the "Reboot" button in the firmware updater, but absolutely nothing happens. I left it running for half an hour and it still didn't reboot so I had to hold the power button down to forcefully reboot the server.

Upon the reboot, the card wasn't able to work anymore, giving the error:

Slot 3 HP Smart Array P410 Controller

1783-Slot 3 Drive Array Controller Failure!

[Command failure (cmd=0h, err=00h, dlu=015:41h)]

Now I can't use this card either. It's like the firmware update bricked the card.

 

 

I originally went with HP because it seemed like the best server hardware to use for me (I wanted to virtualize some VMs, pfSense, etc. for practicing labs for certifications, etc. but now I can't because of this stupid issue. Might as well buy another brand due to this...)

Any help is appreciated. It's either something I'm doing, or it's something that the service pack I'm using is doing. I don't know.

Thanks in advance for any help you can provide.

 

 

2 REPLIES
Torsten.
Acclaimed Contributor

Re: Issue with upgrading firmware with P410i and P410.

If the controller has failed, you cannot update the firmware.

Consider to disconnect the cables between controller and disks and try again. You may also try to remove the cache module for the upgrade. If you see the failed message, the upgrade won't work.


Hope this helps!
Regards
Torsten.

__________________________________________________
There are only 10 types of people in the world -
those who understand binary, and those who don't.

__________________________________________________
No support by private messages. Please ask the forum!

If you feel this was helpful please click the KUDOS! thumb below!   
CrystalPalace
Occasional Visitor

Re: Issue with upgrading firmware with P410i and P410.

I am having the same exact issue. I have swapped out the RAID card for another and replaced the cache and battery. The SPP can still not "see" the P410i controller. It seems to detect it on inventory as it says I need the update, but in the summary of the update, it does not list what version the P410i is currently at. Then the update fials with "0 applicable controllers". This post is the only place I have seen this issue brought up, and I was wondering if you ever solved your problem. I am about to try an older SPP to see if it works.