ProLiant Servers (ML,DL,SL)
cancel
Showing results for 
Search instead for 
Did you mean: 

Lights Out 100i in DL145 G3 Server - virtual kvm/media fails

Joel Stevenson
Occasional Visitor

Lights Out 100i in DL145 G3 Server - virtual kvm/media fails

Hi,

I have a new DL145 with the LO100i "Select Pack" license enabled. I'm trying to use the virutal media feature but am unable to get the applet to load/run properly. Unfortunately the applet that begins to load on the 'Virtual Media' tab throws a couple of exceptions while loading and ultimately does not run successfully. This is true whether I'm logged into the web interface via HTTPS or HTTP.

I've tried using Windows XP Pro/IE 7, and various Macintosh OSX browsers and they all receive the same error:

"General Exception - Optional package installation aborted"

Viewing the stack trace shows that it is a NullPointerException at: "sun.plugin.extensions.ExtensionUtils.extractJarFileName(ExtensionUtils.java:77)"

After the exception is thrown I do get prompted for trust verification on the applet and trusting it seems to successfully start it (the browser reports that it is started).

Thereafter the applet will display the ServerEngines LLC applet copyright and splash screen and prompt for a username and password. Upon submitting valid login information the applet throws a "NoClassDefFoundError: com/serverengines/nativeinterface/NativeInterface".

IPMI Version: 2.0
Firmware Version: 2.14
Hardware Version: 1.0
Description: ProLiant DL145G3

The applet version reported is:

"Remote KVMS Client for Java version 1.0.0 (build: 3867)"

I don't see any firmware updates available for this integrated Lights Out 100 firmware. I'm running JRE 1.5.0_07 (mac) and JRE 1.6 (windows) and the error is the same.

Has anyone else experienced anything similar?

TIA,
Joel
3 REPLIES
KarloChacon
Honored Contributor

Re: Lights Out 100i in DL145 G3 Server - virtual kvm/media fails

hi

try this unistall any java version in a client machine and install this version JRE not SDK

J2SE v 1.4.2_16 JRE

http://java.sun.com/j2se/1.4.2/download.html

regards
Didn't your momma teach you to say thanks!
dms_1
Trusted Contributor

Re: Lights Out 100i in DL145 G3 Server - virtual kvm/media fails

Hi,

according to Lights Out 100i Quickspecks:

Browser Support

Internet Explorer 6.0 SP1 on Windows clients
Firefox 1.5 on Windows and Linux clients
Mozilla 1.7.12 on Windows and Linux clients

So IE 7 is not supported

Macintosh Browsers are not supported too.
Try with IE 6 on a Windows machine or any other of the listed drivers

Regards
Joel Stevenson
Occasional Visitor

Re: Lights Out 100i in DL145 G3 Server - virtual kvm/media fails

Thanks both.

It turns out it was the JRE version. Moving down to 1.4 as Karlo suggested seems to have sorted out the problem. With that JRE I can successfully launch the applet in IE7, Firefox 2, and Firefox 1.5 (all on windows.) No joy on the Mac, but then that's not terribly surprising - and I can live with using XP Pro running in Parallels Desktop to interact with the applet.

Thanks again for taking the time to help me out.