ProLiant Servers (ML,DL,SL)

Lost access to Logicaldrive after change broken cache module

 
Ruben_Herold
Frequent Advisor

Lost access to Logicaldrive after change broken cache module

hi,

I have her an DL380p Gen8. Raid was configured as RAD5+ Hotspare. It seems that the cache module died on the controller. Controller reports an error on bootup.

After exchange the cache module I got the message:

1785-Slot 0 Drive Array not Configured

Configuration information indicates drives were configured on a controller with a newer firmware version. To avoid data loss, reattach drives to original controller or upgrade firmware. ArrayA.png

As you can see the controller is on the newest firmware available.
I have bootet into SSA via Intelligent Provisioning. Looks like the same. But in the Diagnostic report I found something:

In the section "Smart Array Ü420i in Embedded Slot -> Identify Controller:
ArrayB.png

Cache Size in MiB 2GB

But in Section  Smart Array P420i in Embedded Slot -> Cache Config Status:

 

ArrayC.png

Total Cach Memory Size 1 GiB...

13 REPLIES 13
TVVJ
HPE Pro

Re: Lost access to Logicaldrive after change broken cache module

Hello, 

Please refer to page 84 of the HP ProLiant Gen8 Troubleshooting Guide Volume II: Error Messages. The solution provided there requires to power off the server and swap the SAS port connectors. If not move the drives to their original positions, if it were changed.

Regards,

I work for HPE
Views expressed herein are my personal opinion and are not the views of HPE

Accept or Kudo

Ruben_Herold
Frequent Advisor

Re: Lost access to Logicaldrive after change broken cache module

Neighter SAS ports not disks has ben relocated to other locations. But I can try in the next day's

ksram
HPE Pro

Re: Lost access to Logicaldrive after change broken cache module

Hi,

 

Thank you for the POST.

 

Please refer : https://support.hpe.com/hpesc/public/docDisplay?docLocale=en_US&docId=c01647912

 

You may try steps mentioned on the article.

 

I guess a Power Cycle and reseating the Cables would help here and you may trry that.

 

Also do verify if by any chances the Cables were swapped / inserted incorrectly and if you can confirm the Bay / Drive Locations

 

Thank you

RamKS


I work for HPE

Accept or Kudo

Ruben_Herold
Frequent Advisor

Re: Lost access to Logicaldrive after change broken cache module

hi,

we have reseat the cables, nothing changed. We switched the ports, nothing changed. We power cycled the system also nothing changed.

I can't open the last link I got:

 

ArrayD.png

ksram
HPE Pro

Re: Lost access to Logicaldrive after change broken cache module

Hi,

In that Case it would be better to re-create Logical Drives.

Thank you

RamKS


I work for HPE

Accept or Kudo

Ruben_Herold
Frequent Advisor

Re: Lost access to Logicaldrive after change broken cache module

Hi,

sorry this is not acceptable. It can not be the case that if a cache modul failed all logical drives are gone!!

We have a bunch of HPE servers and use them since generation 1 also we have a bunch of storages like 3par (7200, 7440c) and some primeras. If it is true that a broken cache module will kill the whole array we can't no longer trust any of your raid systems.

This system is a test system, this is why it is not on support. But even then ir should be not possible to loose the whole array and logicaldrive cause an cache module failed.

sudhirsingh
HPE Pro

Re: Lost access to Logicaldrive after change broken cache module

@Ruben_Herold 

Based on the snap, write cache show 0% which indicates cache not enabled for the logical drive.

Since you have changed the cache, 

Enable caching for the logical drive from SSA,

Also modify cache read/write ratio,

Hope this helps!

Regards,

Sudhir

While I am an HPE Employee, all of my comments (whether noted or not), are my own and are not any official representation of the company

>Accept or Kudo

Ruben_Herold
Frequent Advisor

Re: Lost access to Logicaldrive after change broken cache module

How should I do if the controller did not recognize the logicaldrive:

 

SSA.png

sudhirsingh
HPE Pro

Re: Lost access to Logicaldrive after change broken cache module

@Ruben_Herold 

All 12 drives are showing as unassigned, seems like array/logical drive information has been cleared from these drives.

What is the critical error/message on the controller ?

In your initial description you have mentioned about cache failure and then you exchanged cache , could you provide more information as what exactly you did ?

Server came with 512MB/1GB/2GB cache module? and did you replaced with exact same capacity ,,new cache ?

or did you swapped cache/ controller from any working machine to this server ?

Few suggestion:

1. Install a new cache module of same size present earlier.

2.Disconnect all the drives, then power cycle the server (without any hdd).

3. Power off and connect all the drives back.

4.Power on the server and check the status in SSA.

Check if you are getting POST message of 1779 ? also if failed array /logical drive information shows in SSA ?

If still nothing, i am afraid to say that you may have to recreate the array.

Regards,

Sudhir

While I am an HPE Employee, all of my comments (whether noted or not), are my own and are not any official representation of the company

>Accept or Kudo