ProLiant Servers (ML,DL,SL)
cancel
Showing results for 
Search instead for 
Did you mean: 

ML 350p Gen8 P420i Raid controller performance problem with 3 x SSD in Raid5

VBO
Frequent Advisor

ML 350p Gen8 P420i Raid controller performance problem with 3 x SSD in Raid5

Dear Friends,


I would spot on a big performance problem with us p420i Raid controller. I would contribute to found and solve the problem.

I have see some performance lack's in the VM's on us new ML 350p Gen8 server.

 

I have found having very slow performances with a 100% Activity time.  After i see.... having around 800-1300ms of response time in the "VHDX storage volume"! And the VM's are actually low usage VM's.

800-1300ms for ssd drives......    Very big problem !  

 

On us old ML 350 G5, we have a 0ms of response time with all big workload VM's. :)

 

Configuration :

 

ML 350p Gen8, 48GB of memory (1600MHZ Registered DDR3) (15GB used), CPU E5-2620, Controller RAID P420i with 2GB of FBWC, 2x 120GB of Intel 520SSD in raid 1 for system, 3x SSD 512GB Samsung 840 Pro in Raid 5 with a 256KB strip size ("transfer speed : 6Gbps").

 

The partition type is ReFS. This is maybe the problem. I work with Microsoft for debug and search if that's can be the problem.

 

 

Any one know or have a performance problem with P420i controller ?

 

 

 

12 REPLIES
VBO
Frequent Advisor

Re: ML 350p Gen8 P420i Raid controller performance problem with 3 x SSD in Raid5

I come back with information's...

 

I am actually looking with Microsoft Partner Support, why the source of the problem (apparently) is the Writes on the ReFS Partition.

 

I tryed to copy 3 files of a total amount of 7.45GB in the same disk (System NTFS Partition with 2x 120Go SSD in Raid 1) on the same controller.


The result : Speed(Disk I/O) between 140 to 340 MB/s, response time of the file transfer 13ms.

Activity : 92%
Queue : 5
 
Two files of a 4.92GB total size from D (ReFS) to C (NTFS) :
Speed(Disk I/O) stable around 458MB/s
Response time around 8ms
C Queue : 0-5
D Queue : 0-5
 
 
Two files of a 4.92GB total size from C (NTFS) to D (ReFS) :
Speed(Disk I/O) stable around 542MB/s
Response time around 6'259ms
C Queue : 0-3
D Queue : 50
Many system Hangs and the Activity time of the disk D let upper to 100% during more about 10minutes after the Transfer be finished !!!!
 
 
 
Wait and see...
VBO
Frequent Advisor

Re: ML 350p Gen8 P420i Raid controller performance problem with 3 x SSD in Raid5

Hello,

 

I come back with news.

Having clearly a compatibility problem between Samsung 840 Pro SSD and HP smartArray P420 Controller.

This is the source of writes problems.

 

I don't know if this is on the Samsung size or HP Size.

I don't have writes problems with the Intel 520 SSD on the same controller.

 

If anyone have suggestion or solution.

Kolio
Occasional Visitor

Re: ML 350p Gen8 P420i Raid controller performance problem with 3 x SSD in Raid5

Thanks for information. I got the same 350p and just wondering about which ssd to buy- 840 pro or s3500. 

dpar95
Occasional Visitor

Re: ML 350p Gen8 P420i Raid controller performance problem with 3 x SSD in Raid5

I am not having good luck with the Intel DC S3500's right now. At this point, I am not sure where the issue is, but the just of it is, I have a

 

DL360 Gen8 with E5-2620

P420i disk controller

4x300GB Intel Dc S3500(raid10)

 

and have installed the latest Centos 6.4 on the system. The Smart Array automatically configured the 4x300Gb S3500's into a raid10 array - I used the default setting and installed Centos 6 to this raid disk. Using LVM with ext4 on the system-- I have added the discard,noatime and nowriteback options to /etc/fstab, as these are suppose to tell the OS to be trim aware and to send this to the disk? I recently attempted to create a new virtual machine with LVM as the disk(to be create in the vg I have with 530gb free), and the system ate all the resources(memory exhausted, cpu very high), and when it was done, all the inodes on the local disk were used. I am not sure where the inodes went, but I am assuming that the data 

 

Is there a setting I need to use in the smart array to allow it to properly see and therefore trim and properly discard ata on SSD drives? I seem to have the latest firmware for the controller, which is from some time last year, and was the latest I found online - please let me know if you know of newer disk controller fw that would help with this? I am really not sure what the next step is to get this system running consistently -- as soon as I added data to the drive(5gb here and then, then deleted), the disk IO went from over a gig, to now just 200mb max. I suspect that my low end p420i with no cache, is not able to communicate with the ssd disks in the correct way, hence the virtual machine using all the inodes?

 

If anyone can point me in a direction to get this system usable in a long term manner, I am all ears - it seemed from reading about the p420i that it was able to talk to ssd drives correctly, so I must have a setting incorrect?

Sbrown
Valued Contributor

Re: ML 350p Gen8 P420i Raid controller performance problem with 3 x SSD in Raid5

1. use raid-1 period.  trust me here.

2. the samsung 840 pro must use 30% OP aka 192gb out of 256 or 384 out of 512 (dont use the 128)

3. don't worry about trim. 

4. ENSURE DRIVE WRITE CACHE is enabled! 

 

the 840 pro is seriously buggy compared to the old 830. Even with the LSI controller.

 

Best bet is to use the software raid (B120i) HPVSA, second best is the LSI2308 (B320i) in IT mode or HPVSA

 

The P420i works fine but the newest "HP SMARTPATH" basically bypasses all the caches to get speed up. It is the equivalent of LSI's cut through switching option (but is dangerous).

 

So if you don't have HP SMARTPATH option , then you must set read to 0% and write to 100% and enable drive write cache.

 

Raid-1 works. Raid-10/5/60 just doesn't scale at all except linear. 

 

Fact is SATA -> SATA is fastest (B120i), then dumb software raid (B320i) then  P420i or LSI.

 

Beware the LSI megaraid product has serious issues with Samsung 840 Pro and Intel S3x00 as well! 

 

PM me if you want to learn more!

 

I have P420/1gb FBWC running in DL180 G6 (and Se1120/p4300g2) - it is a great controller for esxi and the HP SMARTCACHE but its generally too heavy for ssd except with the new smartpath under the right conditions.

 

I use the 840 PRO in DL380G7/DL360 G7/DL320 G6 with LSI megaraid (9260/9261/9266/9271) solid! with 30% OP.

 

So software raid my friend , or raid-1.

 

Maximum performance from the 840 pro on HP gear was using the LSI 9266 (no battery) - I run two of those with 4 to 8 SSD each. 

 

Best esxi performance is with raid-1 smaller strip size !! spanned with extents to make a larger volume. 

 

P420i will disable DWC which kills the ssd literally, and will create strip far too big! P/E of 840 pro is 4K so strip size bigger thank 8K is wasteful! Strip = 1 drive, stripe=all drives. 

 

So yeah you spent a lot of money on a controller that is not well suited for those drives.

 

Did you know folks sell the sandisk or HP branded 400gb SAS ssd for $1/gb on ebay? :) SAS gets rid of a ton of issues.

 

Also never use a sas-expander with SSD. Ensure it is 1 SAS port to 4 ssd maximum. SAS expander will cause tons of issues with SATA SSD to SAS controller.

 

 

VBO
Frequent Advisor

Re: ML 350p Gen8 P420i Raid controller performance problem with 3 x SSD in Raid5

News...

Samsung SSD be send back to Samsung in june. Samsung Found 1 got write problems (frozen ssd). You can simply test each SSD with the Samsung Magician, but on a desktop computer (that's mean you must remove the drive of the array and if possible replace it immediatly). The writes performances be ugly on a desktop computer (like 30MB/s).

 

After replacing drives, no problem... until today


I was see some alternative bad performances on VM's...

 

I would found the problem.

 

Config : 4x 512MB Samsung 840 Pro SSD in Raid 5. (strip size 128KB, Full strip 384KB), verified with Physical Drive Write Cache enabled. Firmeware : updated to 4.68 (1month ago)

SSD Array 100% used (no freespace).

The SSD Wear Gauge always show 100% (maybe it's right, maybe no)

 

 

 

The only one problem I got is an alternative performance.   I proof it below.

Discovered why VM is slow...

 

After, i try to found a solution.

I test with SmartArray Accelerator disabled on this SSD Array. Test_02_SMA_Disabled.png

Not very good.... :)

 

After, i tryed to enabled back the SmartArray Cache with, same like origine, 10-90%

Test_02_SMA_10-90_back.png

 

Maybe the Controller be in a not good state mode after firmware upgrade and disabling the SmartArray Accelerator, then enabling it back again resolve a bug ?!?!

VBO
Frequent Advisor

Re: ML 350p Gen8 P420i Raid controller performance problem with 3 x SSD in Raid5

You need FBWC Cache !

I tried to disable Cache (smart array accelerator) look. :) 

 

Test_02_SMA_Disabled.png

 

For perf with SmartArray accelerator enabled, just look upper.

VBO
Frequent Advisor

Re: ML 350p Gen8 P420i Raid controller performance problem with 3 x SSD in Raid5

Anyone have good experience with Kingston E50, KC300 or Intel DC S3500 ?
jaustria
Occasional Visitor

Re: ML 350p Gen8 P420i Raid controller performance problem with 3 x SSD in Raid5

Any luck with the 840 pro drives?

LIT_MJ
Occasional Visitor

Re: ML 350p Gen8 P420i Raid controller performance problem with 3 x SSD in Raid5

Sorry for Hijacking the thread. how did you attach the SSD' did you get a SATA BackPane or did you use somehting else ? I Have asked our distributer but they will not help me as this is not a standart config.

Torxb
Occasional Advisor

Re: ML 350p Gen8 P420i Raid controller performance problem with 3 x SSD in Raid5


LIT_MJ wrote:

Sorry for Hijacking the thread. how did you attach the SSD' did you get a SATA BackPane or did you use somehting else ? I Have asked our distributer but they will not help me as this is not a standart config.


Search Amazon for:

Tripp Lite Internal SAS Cable, 4-in-1 32Pin (SFF-8484) to 4 x 7pin Cable, 20-in. (0.5M)(S502-20N)

 

 

RbBsmn
Regular Advisor

Re: ML 350p Gen8 P420i Raid controller performance problem with 3 x SSD in Raid5

Non-supported configuration, thats why you got performance issues.
Did my post help? Thank me with kudo's! :)