ProLiant Servers (ML,DL,SL)
cancel
Showing results for 
Search instead for 
Did you mean: 

ML 370 Smart Array 2 (embedded) Mesage won't go away

SOLVED
Go to solution

ML 370 Smart Array 2 (embedded) Mesage won't go away

Whenever I create an array / logical drive with this machine, I will see the following message at boot and within the OS - SA Config utility:

# 785 Background parity initialization is currently queued or in progress on logical drive 2 (RAID 5 in array B). If background parity initialization is queued, it will start when I/O is performed on the drive. When background parity initialization completes, the performance of the logical drive will improve.

This is all fine - except - the message never goes away. even after a week...

Can this be normal?
18 REPLIES
Sean Marshall_1
Frequent Advisor

Re: ML 370 Smart Array 2 (embedded) Mesage won't go away

ok, this can be normal. Have you witen anything to this logical drive yet? The parity actually waits until there is I/O on the drive before it begins. If you have writen to the drive already, What is the status of the array? Is it in in a rebuild state? (what is the firmware and driver rev your using as well?)

Re: ML 370 Smart Array 2 (embedded) Mesage won't go away

In the past I had set this array as the Exchange 2003 location, which would get a lot of IO. (and message never cleared) Currently it is just sitting as a logical drive, no files on it.

Firmware Version is 1.50
Driver is 5.14.0.0

Re: ML 370 Smart Array 2 (embedded) Mesage won't go away

Forgot to add - The array is in a "normal" state - no rebuilding or other actions taking place.
Sean Marshall_1
Frequent Advisor

Re: ML 370 Smart Array 2 (embedded) Mesage won't go away

Try writing a small file to the disk then see what happens. The I/O might start the parity.

Re: ML 370 Smart Array 2 (embedded) Mesage won't go away

Since my last post, I have moved my Exchange databases, enabled shadow copies & created a swap file on the drive. Now there is some I/O happening.
How much time should pass before this finishes?
How do I know if it has even "started", I wonder?

Thanks
Chris
Sean Marshall_1
Frequent Advisor

Re: ML 370 Smart Array 2 (embedded) Mesage won't go away

The average time for the "Parity" is about 15-20 mins per gig of the entire Array. (If you have a BBWC (longer if not).
Are the hard drive Leds blinking?

Re: ML 370 Smart Array 2 (embedded) Mesage won't go away

No - Not blinking as I would expect (like when expanding & such) - normal disk i/o is the only time they appear to be active.
The status for this array reports
"Status Background Parity Initializing/Queued "

Thanks
Chris
Sean Marshall_1
Frequent Advisor

Re: ML 370 Smart Array 2 (embedded) Mesage won't go away

Can you run the ADU and post the results?

Re: ML 370 Smart Array 2 (embedded) Mesage won't go away

Hmmm.. OK I think this is what you mean - If not, let me know. (See attached)

Thanks
Sean Marshall_1
Frequent Advisor

Re: ML 370 Smart Array 2 (embedded) Mesage won't go away

Download this and attach the report.txt

http://h18023.www1.hp.com/support/files/server/us/download/15125.html

I'll see if I can decipher the Hex code in it. :)

Re: ML 370 Smart Array 2 (embedded) Mesage won't go away

Well -

SCSI Port 1 Drive ID 2 is not stamped for monitoring

Is an error that jumps out at ya... Have to figure out what that means - and how to fix it.

Do you know this error?

Text file attached as requested.

Thanks in advance.
Chris

Re: ML 370 Smart Array 2 (embedded) Mesage won't go away

Not sure if it is just me - but the attached file (when I view it from here) was a previously submitted file. Let me try it again - OK sorry I see what I did wrong. THIS file is the diagnostic result.
Sean Marshall_1
Frequent Advisor

Re: ML 370 Smart Array 2 (embedded) Mesage won't go away

Hmmm well the last post might have hit it on the head (SCSI Port 1 Drive ID 2 is not stamped for monitoring). You may need to use the M&P (Monitoring and Performance)patch. Try this link:
http://h18000.www1.hp.com/support/files/server/us/download/10468.html

This might be the issue.


Re: ML 370 Smart Array 2 (embedded) Mesage won't go away

Sean -

Was hesitant to run the utility on the drives due to the wording:

"The M&P Patch Utility eliminates the traditional hard drive M&P tests and associated thresholds. Compaq Insight Manager will show these tests as N/A (Not Applicable) in the hard drive monitoring section of the application."

Not sure if this is going to indiscriminately change all of my drives and prevent proper monitoring??

In the meantime, I replaced the one drive that showed the error and the array is currently rebuilding.

Please let me know if you think I am off-track about the utility.

Thanks Much
Chris

Re: ML 370 Smart Array 2 (embedded) Mesage won't go away

Newly replaced drive is working fine in the raid 5 array. The original error is now gone. Would still like clarification on the utility issue / function.

Thanks very much for your help.
Sean Marshall_1
Frequent Advisor
Solution

Re: ML 370 Smart Array 2 (embedded) Mesage won't go away

The other drive is still a good drive. It just needs the M&P patch to stop reporting that error. I would install it in a test server and run the patch - then you would have a spare drive again.

Re: ML 370 Smart Array 2 (embedded) Mesage won't go away

10-4
I still have the spare that was originally configured as such, but you never know when you are going to need another.

Thanks for helping solve my mystery - gave you a bunch of points - not sure what that's worth - but it's the best I can do.

Thanks again

Chris
Sean Marshall_1
Frequent Advisor

Re: ML 370 Smart Array 2 (embedded) Mesage won't go away

Glad I could help!

Thanks for the points!!

:)