ProLiant Servers (ML,DL,SL)
cancel
Showing results for 
Search instead for 
Did you mean: 

ML110G5 degraded RAID1, logical drives showing up twice

Martijn de groot_2
Occasional Visitor

ML110G5 degraded RAID1, logical drives showing up twice

Hi all,

We are running Windows Server 2008 SBS on a ML110 G5.
We've built a RAID1 config on the embedded Adaptec RAID controller using two 750Gb SATA disks.
I have installed Adaptec Storage Manager 6.50.00 to watch the health of the RAID configuration and to receive mails when something goes wrong.
After the last Windows update ASM started to issue messages that my logical devices were degraded.
For some reason my logical device shows up twice in ASM, with identical names and data, see ASM screenshot1.jpg.
What's more, in Windows Explorer my drives and partitions show up twice too, my C: and D: drive have copies F: and G: holding the same data.
I've updated my embedded RAID driver to v. 17021, updated my BIOS and updated my windows to the latest version.

Does anybody know how to fix this?

Best Regards,

Martijn.
3 REPLIES
Suman_1978
HPE Pro

Re: ML110G5 degraded RAID1, logical drives showing up twice

Hi,

I would first check the Disk Management and try to do delete the extra drive letter if possible.
http://technet.microsoft.com/en-us/library/dd163558.aspx

See this, it may give you an idea to fix the issue:
http://www.mydigitallife.info/2007/11/08/change-or-delete-system-drive-letter-via-registry-to-remove-conflict-usb-or-firewire-drive-letter/

Thanks
Martijn de groot_2
Occasional Visitor

Re: ML110G5 degraded RAID1, logical drives showing up twice

Hi an.suman,

Thanks for you reply.

I'm afraid your solution didn't work; when I open Disk Management I can see drive C: and D:, as well as drive F: and G:.
See attached file DiskManager.jpg for clarification.

For some reason my RAID1 configuration has dissolved into two separate drives, with their own set of data. The data on disk 1 and 2 should be kept identical by the RAID controller, I shouldn't even see both diskdrives but only one.
The problem seems to be the RAID controller or RAID configuration.

Has anyone experienced the same problems after doing Windows Updates on januari 14th?
Anyone that can help me restore my RAID data without reformatting and restoring from backup?

Thanks in advance.

Regards,

Martijn.

Hi,

I would first check the Disk Management and try to do delete the extra drive letter if possible.
http://technet.microsoft.com/en-us/library/dd163558.aspx

See this, it may give you an idea to fix the issue:
http://www.mydigitallife.info/2007/11/08/change-or-delete-system-drive-letter-via-registry-to-remove-conflict-usb-or-firewire-drive-letter/
Martijn de groot_2
Occasional Visitor

Re: ML110G5 degraded RAID1, logical drives showing up twice

No solution found.
I had to format, make partitions and reinstall from backup.

Case closed.