ProLiant Servers (ML,DL,SL)
cancel
Showing results for 
Search instead for 
Did you mean: 

ML115 G5 - Running Vista - nvstor.sys BSOD

zoomzoomvince
Occasional Visitor

ML115 G5 - Running Vista - nvstor.sys BSOD

I have got a new ML115 G5 and I have installed Vista Ultimate on it - I know its not a supported OS but I don't need 2003/2008 Server.

Anyway, it crashes sometimes (BSOD) on nvstor.sys - which I beleive is related to an nvidia driver. I have a single SATA drive and the raid is disabled in the BIOS. Does anybody have any ideas ??

Much appreciated.
8 REPLIES
Blazhev_1
Honored Contributor

Re: ML115 G5 - Running Vista - nvstor.sys BSOD

Hi,

if you will feel better, there are a lot of users experiencing the issue, e.g. :

http://forums.techarena.in/vista-hardware-devices/699626.htm

According to
"17-03-2007
Jill Zoeller [MSFT]

An update: this is bug in nvstor.sys. We are planning to release an updated
driver via Windows Update "

Since this was more than an year ago, there should be a fix, checking the same

regards
Blazhev_1
Honored Contributor

Re: ML115 G5 - Running Vista - nvstor.sys BSOD

hi,

found another abou 100 forums discussing on the same. mMost of the threads stopped being updated about octomber/november 2007. Do you have all Vista updates? Seems like MS released the fix. Just to be sure you can run the windwos update and monitor the server. In most of the cases , the BSOD occurs when starting backup.

regards
BobHard
Occasional Visitor

Re: ML115 G5 - Running Vista - nvstor.sys BSOD

I am having an even more annoying problem which is preventing me from installing Vista Home Basic on my new ML115 G5 at all.

Shortly after starting the Vista install I get the BSOD and quoted error message regarding nvstor.sys. I have read on other forums that the file is not related to Nvidia but to the SATA storage which would seem to fit with my experiences. I am currently running XP but would really like to install Vista. XP, by the way, does not see my 4GB of RAM but only 2.35GB since I installed SP3.
andre_b_1
Occasional Visitor

Re: ML115 G5 - Running Vista - nvstor.sys BSOD

Hi

I had the exact same problem.
For some reason Vista does not like the HDD that comes with the server.

I tried a different HDD and it works fine now.

I hope this helps

Andre
andre_b_1
Occasional Visitor

Re: ML115 G5 - Running Vista - nvstor.sys BSOD

I forgot to mention, it is with regards to installing Vista.

Regards
BobHard
Occasional Visitor

Re: ML115 G5 - Running Vista - nvstor.sys BSOD

Thanks Andre_b, for confirming that this is definitely related to the hard drive/storage drivers. Employers have given me a license for W2K3 and that is now installed and working 100% after trimming down to be a workstation. I read that Vista also has problems seeing 4GB RAM.
Prabhu Raj
Frequent Advisor

Re: ML115 G5 - Running Vista - nvstor.sys BSOD

I believe this server uses nVidia NFP3400 chipset and the issue is related to the same.

Install the vista chipset driver for nVidia NFP3400 (if available) and i am sure your issue will be resolved.
Prabhu Raj
Frequent Advisor

Re: ML115 G5 - Running Vista - nvstor.sys BSOD

Information about the chipset can be found at
http://www.nvidia.com/page/nforce_pro_server.html

and the drivers can be downloaded at

http://www.nvidia.com/object/nforce_vista_15.16.html

Confirm the details before downloading and installing.