ProLiant Servers (ML,DL,SL)
cancel
Showing results for 
Search instead for 
Did you mean: 

ML150 G3 with dead slow disk write

 
Mark Tobin
Occasional Advisor

ML150 G3 with dead slow disk write

Brand new ML150 G3 with HP 8 Internal Port SAS Host Adapter with 2 x 250GB HDD's in RAID 1 configuration, running SBS2003 R2.
Server seemed a bit sluggish on the install but things really went bad after joining clients to the domain and setting up a network share. Copying files to the share was very slow and opening any file on the share takes 2 times as long compared to another network share residing on an old workstation.

Tried latest drivers for the nics, updated the firmware for the SAS controller, swapped switches and cables, tried disabling SMB Signing. Also had other SBS Specialist take a look. Could not find any cause.

In desperation installed Performance Test software on the server and performed a hard disk test. Every score came out lower that my 4 year old desktop. The most amazing result though is the Sequential Write. My poor old desktop pumped out 40.3 MBytes per sec. The brand new ML150 only mangaged 1.65 MBytes per sec. You are probably reading this saying the decimal point is in the wrong position. To confirm; 1.6 MBytes per second.

Where does the fault lay? My money is on the controller. This server is supposed to be fully commissioned in one week. Without a box of spares in my toolkit I don't know how this deadline can be made.

Any ideas?
5 REPLIES
Mauro Rusignuolo
Trusted Contributor

Re: ML150 G3 with dead slow disk write

Hi Mark,

I suppose the HDs you have installed are SATA.
I have an identical server.
At the moment, I can suggest to you tu use the Embedded Sata Raid instead of the SAS Host Adapter.
So you can have additional information in order to determine the problem.
(may be the SAS Host Adapter.)

Let me know.

Bye.

<> Leonardo da Vinci
Mark Tobin
Occasional Advisor

Re: ML150 G3 with dead slow disk write

Hi there,

Yes you are correct Sata drives, 250GB.

What more can you tell me?
Mauro Rusignuolo
Trusted Contributor

Re: ML150 G3 with dead slow disk write

Hi Mark,

so, let me say:
if you want to use, immediately, the two HDs SATA in raid, without using the SAS Host Adapter (only for a test, at the moment, I mean), you have to detach (unscrew) the two HDs from the hot swap support.
connect the SATA HDs to the connectors (blu) of the embedded sata raid.
enable the embedded sata raid via bios.
load the correct driver during the installation process.

there are new firmware update to fix some bugs regarding the embedded sata raid (but if you have already installed the latest version of bios, you don't need. but the way, here is the link).

http://h18023.www1.hp.com/support/files/Server/us/download/26445.html?dimid=1477400834&dicid=alr_feb07&jumpid=em_alerts/us/feb07/all/xbu/emailsubid/mrm/mcc/loc/rbu_category/alerts

let me know.

Bye.

TJK
<> Leonardo da Vinci
Mark Tobin
Occasional Advisor

Re: ML150 G3 with dead slow disk write

TJK

Thanks for the advice. I actually had the server running on the embedded RAID while I was waiting for the cables for the SAS adapter.

Is there a resolution for the SAS adapter? Or should I take this up with HP?

Thanks again for your help.

Mark
Mauro Rusignuolo
Trusted Contributor

Re: ML150 G3 with dead slow disk write

Hi Mark.

Thank you for your words.
are a great reward.
better than "points".

at the moment I'm not able to say you anything more about the SAS controller (HBA) installed on your server.

do yu suppose may be the cable?
may be...

if you have checked connections and cable ... and the controller is correctly fitted into the PCI-X slot ...
you can only test the cable, changing it if you, oblviously, don't have a "spare" controller to install and test...

let me now.

Bye.
TJK.
<> Leonardo da Vinci