HPE Community read-only access December 15, 2018
This is a maintenance upgrade. You will be able to read articles and posts, but not post or reply.
Hours:
Dec 15, 4:00 am to 10:00 am UTC
Dec 14, 10:00 pm CST to Dec 15, 4:00 am CST
Dec 14, 8:00 pm PST to Dec 15, 2:00 am PST
ProLiant Servers (ML,DL,SL)
cancel
Showing results for 
Search instead for 
Did you mean: 

ML310 G1 ATA embedded Raid

 
SuperJeet66
Occasional Visitor

ML310 G1 ATA embedded Raid

I have a customer with an ML 310 G1 that has the onboard ATA Raid controller. Last year I replaced existing raid disk (80gig) with two 160gigs....its been working fine at Raid 1 for over a year. A couple weeks ago the server wouldnt boot because of a bad disk in the array. I tried to repair the disk and rebuild the array but it failed 1/2 way through and damaged both disks. I rebuilt the server with little data loss and now that I have a good disk again a week later (at Raid 0) I inserted a brand new disk of exact same type, and upgraded to Raid 1 with the new disk in and it failed with error (unable to complete rebuild press ESC) I escaped and rebooted and it damaged my good disk again.... I am ready to freak out here... does anybody know how to recover from such an error ie.. bad disk. I believe it wiped my boot sector and partition info as I put the drive in another machine and it only sees it as a blank disk. Any help would be great ... other wise I am back to the drawing board...again. Thanks very much
7 REPLIES
Mi6t0
Trusted Contributor

Re: ML310 G1 ATA embedded Raid

First of all it is a good idea to update to the latest firmware versions.
I am not sure what option you have in the bios but is it possible to create a raid with 150 of the 160 gigs? Just in case if the HDDs do not have the same size.

Another good idea is to check the HDDs for bad-sectors.
SuperJeet66
Occasional Visitor

Re: ML310 G1 ATA embedded Raid

Thanks for the reply....
This server came with an embedded LSI Logic MegaRaid Ultra ATA 100 Controller. I cannot find a firmware update on the LSI or the HP sites. I am hoping someone out there can tell me where to find updates for this as the LSI support referred me back to HP. Thanks in advance.
Blazhev_1
Honored Contributor

Re: ML310 G1 ATA embedded Raid

Hi,

I can't find a firmware update for the ATA 100 controller(it is the same as in ML330 g3), there are only drivers...strange.
Normally if the rebuild don't complete, the reason are bad sectors, the data can't be reconstructed and the rebuild hangs...it is recommended t make a backup, to replace the drives and to restore...you can try other things, but I think that at the end you will end up there too..

Pac
SuperJeet66
Occasional Visitor

Re: ML310 G1 ATA embedded Raid

Pac,
Thanks... I thought I was crazy but I have only found drivers as well.
I am not familiar with the 330 series so I am not sure if same controller.
Here is the really strange part, when this happened the first time it was surely due to bad sectors as the array was flagged as degraded. The process of rebuilding the array hosed both disks. I finally figured out which disk was suspect and I recovered the data and re-installed server 03. But in order to do this I had to use Raid 0 because I did not have the replacement disk yet. So now I have thier system all set and ready for Raid 1 .... I follow all LSI Logic instructions for upgrading to Raid 1 using an existing disk with a new disk (which tested out good) and it still aborted after about 30 seconds telling me there were no partitions on the target disk and that there was an error in rebuilding. I understood the target disk to be the "new" blank disk but it seems like it tried to copy the "new" blank disk to the old good data disk... subsequently hosing me again. Did I do something to anger the raid gods ? Thnanks
Blazhev_1
Honored Contributor

Re: ML310 G1 ATA embedded Raid

Hello,

unfortunately you can't make a raid migration with ORCA...If you made raid 0 and you want to migrate it to raid 1 with F2, you must make backup and restore. Don't know if it is officially documented somewhere. If it is acceptable for you, you can delete, then create RAID 1 and install new...the ultra 100 ata is not so intelligent like the smart arrays.
About the firmware I think that it is embedded in the system ROM of the server. There are some public advisories that advise ROM update by problems with the storage controller.

Regards,
Pac
SuperJeet66
Occasional Visitor

Re: ML310 G1 ATA embedded Raid

Thanks very much... although not great news and lots more work ... it clarifies things.
SuperJeet66
Occasional Visitor

Re: ML310 G1 ATA embedded Raid

Going back to the rebuilding RAID 1 drawing board.