ProLiant Servers (ML,DL,SL)
cancel
Showing results for 
Search instead for 
Did you mean: 

ML330 G6 - Unable to update bootblock ROM

Mark Welte
Occasional Visitor

ML330 G6 - Unable to update bootblock ROM

I am working on a ML330 G6 server that has the dual processor kit installed. There is a problem with the ROM that shipped with the server where it will hang if the second processor is installed during a BIOS upgrade. Here is the advisory from HP:

Advisory: ProLiant ML330 G6 Server - The Server May Stop Responding After a Second Processor Is Installed

 

The solution is to upgrade the Bootblock ROM to a newer version. When I run the upgrade utility I receive this error:

 

BootBlock ROM Flash Utility v1.2 03/31/10
HP ISS Platform Server BIOS Validation Group
Copyright 1982, 2010 Hewlett-Packard Development Company, L.P.

BootBlock ROM A: 03/16/09
BootBlock ROM B: 06/01/09

Unlocking ROM...
Erasing ROM sector...
All done...

Errors:
Unknown Command (6Dh) in ROMpaq Flash Table
Timeout Erasing Sector

Comparing BootBlock ROM images...

Data miscompare at offset: 31CDh.  BB_A: B8h,  BB_B: 25h

....

 

BootBlock ROM A: 06/01/09
BootBlock ROM B: 03/16/09

 

Any ideas on how to correct this? It is a real pain having to remove the second processor and daughter card every time we upgrade the bios.

 

Mark

2 REPLIES

Re: ML330 G6 - Unable to update bootblock ROM

Perform the workaround detailed in the advisory again and attempt to update the boot block.

 

 

 

Regards,

 

Vijayasarathy

I work for HP
To say thanks click the white "thumbs up" icon below!!!
Mark Welte
Occasional Visitor

Re: ML330 G6 - Unable to update bootblock ROM

The work around has been done and the Bootblock ROM will still not install. I have installed the second processor and tried it, tried it without the second processor, reset the CMOS and NVRAM. Still unable to upgrade.

 

Is it normal for the Bootblock ROMS to be different? Looking at the log files and ther error code it appears that the update program is expecting ROM A and ROM B to have the same dates. Is this normal, or did I get a motherboard that is goofy?

 

BootBlock ROM A: 03/16/09
BootBlock ROM B: 06/01/09