ProLiant Servers (ML,DL,SL)
cancel
Showing results for 
Search instead for 
Did you mean: 

ML330 - IDE RAID woes (vmware, Linux, netware, you name it !)

Michael Jezard
Occasional Contributor

ML330 - IDE RAID woes (vmware, Linux, netware, you name it !)

I purchased an ML330 some weeks back, (2.4GHz, 2 * 80Gb IDE, 1.2Gb mem )specifically to use as an R&D platform to learn Netware 6.5 and SUSE Linux.

The intention was to Load SUSE then run VMWare to run Netware 6.5

However, I tried for the longest time to load SUSE and when I finally got it running, I could never get VMWare to run because of the hoops I'd had to jump through with the IDE RAID Drivers.

I've configured the RAID for RAID 0 and the thoughput is miserable ( 5Mb/sec for write)

but,I eventually loaded W2003 as main OS, loaded VMWare, then tried to load Netware 6.5, but every time the server reboots after the install is complete, Novell ends up in a "abend loop" which appears to have something to do with the IDE driver that's being loaded.

I've had it with this IDE RAID controller, and I'm pretty close to having had it with the server ( If I hadn't been stupid and thrown the box out, it would be in the mail back to CDW !)
So, now that I'm stuck with it, I think the ONLY way I'll ever gert any use out of the thing is if I completely bypass the IDE RAID and just use regular IDE drivers.

So, after that longwinded intro, here's the question:

How can I disable the RAID Controller and get the ML330 to boot from regular IDE channel?. Do I have to move the drives to the other connector, will the BIOS recognize this and allow me to boot?. What other problems will I bump into?.

Hoping for help


Michael
3 REPLIES
Leonard Davison
Frequent Advisor

Re: ML330 - IDE RAID woes (vmware, Linux, netware, you name it !)

Michael..

The default raid controller in the ML330 does not have a write cache. It only has a read cache (Compaq/HP's way of getting people to buy more expensive controllers I guess.) So that explains the poor write performance.

Do you have the latest Proliant Support pack (ver 7.00a) for Netware from the web site?
http://h18023.www1.hp.com/support/files/server/us/locate/89_1349.html.
The driver Novell detects vs. the driver installed during a Smart Start install are different and is probably causing the issue. Have you tested installing Netware from the Smart Start assisted install?

It really sounds like a "detected" driver problem due to the fact that Win2003 loaded well....
e4services
Honored Contributor

Re: ML330 - IDE RAID woes (vmware, Linux, netware, you name it !)

I agree. Unfortunately the standard controller is provided as a marketing tool. Being able to use the word RAID in the description, sells more servers. The fact that it is a simple RAID is lost in the translation. The use is better suited for the Workstation, like the one I have here, I never see and problem because I never have that large of transfers. But a server is another story. Consider upgrading to the latest Adaptec IDE RAID. It is more suitable to your application.
Hot Swap Hard Drives
Michael Jezard
Occasional Contributor

Re: ML330 - IDE RAID woes (vmware, Linux, netware, you name it !)

The question still remains, can I disable the RAID controller ( hardware / software) and will I be able to get the server to boot.

I'm getting nowhere with my Netware installation (in a VMWare session) as the drive seems to "scramble" every time. I'm convinced that if I just had regular drivers on the W2003 installation then this wouldn't be happening.

Michael