ProLiant Servers (ML,DL,SL)
cancel
Showing results for 
Search instead for 
Did you mean: 

ML330 - no bootable drive configured on this system

Herb Ludwig
Occasional Visitor

ML330 - no bootable drive configured on this system

Please Help! I have a ML330 G3. It was previously operating on a single HD without any RAID configured. The system is now rebuilt with the following:

2 X Hitachi ATA-133 Hard Drives 400MB, these are on their individual IDE cables, and both set to cable select.
Bios Updated today with a version from Sept 2005 (the latest available)
The boot controller is: CSB-6 Ultra ATA-100 IDE RAID Controller. There is a generic controller on the RBSU, HP Integrated PCI IDE Controller, but I cannot change the order to make it first.

I tried booting the server with a couple of other IDE drives, with no change to the errors.

Everything on the RBSU looks great. Both drives are showing, and I've done the initialization. No flags on this.

When using Smartstart 8.1, it shows that there is a boot controller as above, but the Boot Controller Disk Size is 0.

I've tried to boot from a Windows 2003 disk, and I get the message that there are no drives to boot to.

I thought that updating the BIOS would lead to success, but I've had NO SUCCESS. I'm starting to see these bios screens in my sleep. If you have any suggestions, I'd appreciate them.

3 REPLIES
Steven Clementi
Honored Contributor

Re: ML330 - no bootable drive configured on this system

Herb:

There must be some configuration utility for the RAID card that you can press a key to get into during boot time.

If the server is seeing the drives, then it is just a matter of creating an array out of them and making a logical drive. Once you have a logical drive, SmartStart and/or Windows should see a bootable disk to utilize.

For a Smart Array controller, you can simply press f8 once the bios is done loading/scanning for drives.

Reboot the box and watch the console... loog for your array controller bios to load and some indication as to the key combo to press.


Steven
Steven Clementi
HP Master ASE, Storage and Clustering
MCSE (NT 4.0, W2K, W2K3)
VCP (ESX2, Vi3, vSphere4, vSphere5)
RHCE
NPP3 (Nutanix Platform Professional)
Herb Ludwig
Occasional Visitor

Re: ML330 - no bootable drive configured on this system

Thanks for your reply. I took another look at the RBSU utility, and a closer look at the array. I rebuilt the array for good measure, which took several hours. The bios messages show both hard drives, and an array of Raid 1. I cannot find the method to make a logical drive from what I'm seeing / not seeing.

When in Smartstart, the ACU does not detect any controllers on the system. It finds a boot controller, CSB-6 Ultra ATA-100 IDE RAID Controller, and still a size of zero.

You mention a RAID card. Looking at this server, I do not have a specific card. I just want to have redundant drives under RAID 1. Both drives are connected directly to the motherboard. Am I mistaken, or is there another fundamental that I may be missing?
Herb Ludwig
Occasional Visitor

Re: ML330 - no bootable drive configured on this system

In the ROM-Based setup utility (after pressing F9) I have a choice of 2 Boot Controllers:

PCI Embedded CSB-6 Ultra ATA-100 IDE RAID CONTROLLER

and

HP Integrated PCI IDE Controller

I have tried multiple times to get the order of these to change, and perhaps just use the 2nd controller so I can at least have a working server. I'm throwing in the towel. How can I get this to run without RAID? Then I can get this thing going. Thanks tons in advance.