ProLiant Servers (ML,DL,SL)
cancel
Showing results for 
Search instead for 
Did you mean: 

ML350, 2610SA, and Hot-swap

 
davep
Occasional Visitor

ML350, 2610SA, and Hot-swap

I have an ML350 with an adaptec 2610SA (HP OEM). I can't figure out how to get the drives to hot-swap. I can simply remove them, but the system (WXP Pro SP2) won't recognize re-inserted drives without a reboot. The drives are recognized in the XP pro device manager as "Adaptec Array SCSI Disk Devices". The option for "Optimize for Quick Removal" is grayed out. The "HP Storage Manager" app seems to offer nothing. If I disable the devices in device manager, power will shut off, but again, simply re-enabling won't do it. I have to restart the system to recognize them again. The specs clearly say that the components support hot-swap, so what gives?
6 REPLIES
Basil Vizgin
Honored Contributor

Re: ML350, 2610SA, and Hot-swap

Did you try to rescan disks in Disk Management?
davep
Occasional Visitor

Re: ML350, 2610SA, and Hot-swap

I have rescanned after re-insertion. Same result.
davep
Occasional Visitor

Re: ML350, 2610SA, and Hot-swap

I re-checked all three of the download versions you mentioned, and all are up to date. It was worth checking again though.
Basil Vizgin
Honored Contributor

Re: ML350, 2610SA, and Hot-swap

Did you install SATA RAID Event Notification Daemon for Windows 2000/Windows Server 2003?
http://h18007.www1.hp.com/support/files/server/us/download/22270.html
davep
Occasional Visitor

Re: ML350, 2610SA, and Hot-swap

I wasn't sure Basil, so I installed it (maybe again). Unfortunately it didn't seem to make a difference. Should I be seeing a "safely remove hardware" icon, or should it show up after a "rescan" click in HP Storage Manager? Or, should the controller simply recognize and re-enable immmediately?

thanks for the thoughts so far,
Dave