ProLiant Servers (ML,DL,SL)
cancel
Showing results for 
Search instead for 
Did you mean: 

ML350 G4 with failed RAID

 
R_Sulli
Occasional Visitor

ML350 G4 with failed RAID

I need some suggestions for trying to recover a failed RAID array. The array is in an ML350 G4 with a Smart Array 641 controller card. The RAID consisted of 3 36.4GB drives configured for RAID 5. This is the only logical drive on the machine and it had the OS (Windows 2000), programs and a small database. Unfortunately, I have very little confidence in being able to restore from the backups of the server. My best hope for recovery is to be able to rebuild the RAID array or at least recover most of the data from it. Biggest mistake made already by not having at least two usable backups!

 

- When the system failed to reboot, I entered the ROM Configuration for Arrays Utility. It reported the drive in slot 0 as OK, no report for the drive in slot 1 and the drive in slot 2 as REPLACEMENT. I don't understand why the RAID didn't continue to function at this point with two apparently working drives.

 

- I ran the diagnostics in the offline version of the HP Array Configuration Utility. It reported the drives in slot 0 and 2 as functional and the drive in slot 1 as failed. It also reported the logical drive as failed and all data lost. Not a good sign!

 

- In an attempt to recover whatever data I could before replacing the drive, I decided to find and use data recovery software. Since I don't have any other computers or enclosures with SCSI connectors, I installed an IDE drive in the ML350 on which to install an OS and recovery software. After several failed attempts and a little research, I came to the conclusion that an ML350 won't boot from an IDE drive. In this process I probably made my next biggest mistake by removing the Array Controller from the server.

 

- I found some matching HP hard drives, reinstalled the Array Controller, unseated the 3 original drives, added a new drive to an open slot and turned on the server. In going to the ROM Array Config, I discovered that the original logical drive config was now gone. Moving ahead, I configured the single drive as RAID 0 and installed Windows 2000. I reinstalled the 3 original drives in their appropriate slots without doing any configuration.

 

- I ran the ACU diagnostics again. It still reports the drives in slots 0 & 2 as functioning, but no longer sees the failed drive in slot 1.

 

I have tried running several different data recovery tools that supposedly work with RAIDs, but none of them see any of the original drives. If I try to configure another logical disk with the original drives, won't it wipe any data that is on them? Is there any way to see the failed drive in slot 1? Is there any way to recover the original RAID configuration?

 

I'm open to any helpful suggestion, though any solution costing more than $2000 or so probably won't happen.