ProLiant Servers (ML,DL,SL)

ML350 Gen9 8SFF drive cage, SATA HDD drive not visible

Go to solution

ML350 Gen9 8SFF drive cage, SATA HDD drive not visible

I'm trying to connect a
Seagate HDD Internal 5 TB BarraCuda SATA 2.5 Computer Hard Disk Drive

through my 8FF backplane (777279-001) to my HPE proliant ML350 Gen9 running Ubuntu Server 21.04
I'm using a Mini SAS cable (788453-001) that runs from the backplane to the motherboard (see a photo of this )

I can't see the hard drive in Ubuntu or in the HPE 'Intelligent provisioning' in-built program that i run from the BIOS menu.
The 8SFF backplane seems to have power (power lead attached aswell as SAS cable) because when i push the hard drive into the backplane the lights on the  front of the SFF Hot-Swap Caddy light up but then remain off.

I'm thinking im missing something or doing something wrong can any suggest something? I've been trying so many different configurations in the BIOS like enabeling RAID andnothing seems to get the hard drive to show to the system.





Re: ML350 Gen9 8SFF drive cage, SATA HDD drive not visible

Hi @curtb
Please check if you have enabled SATA AHCI Support.
The in-distro ahci driver should pickup the device automatically.
Enabling embedded chipset SATA controller support
• The correct operating system drivers for your selected option.
Boot Mode is set to UEFI Mode.
1. From the System Utilities screen, select System Configuration > BIOS/Platform Configuration(RBSU) > System Options > SATA Controller Options > Embedded SATA Configuration and press Enter.
2. Ensure that you are using the correct ACHI or RAID system drivers for your SATA option.
3. Select a setting and press Enter.
a. Enable SATA AHCI Support—Enables the embedded chipset SATA controller for AHCI.
b. Enable Dynamic Smart Array RAID Support—Enables the embedded chipset SATA controller forDynamic Smart Array RAID.
4. Press F10.
I am a HPE Employee

Accept or Kudo


Re: ML350 Gen9 8SFF drive cage, SATA HDD drive not visible

Hey @WouterH thanks for the reply.

I have tried both of those options but the hard drive does not appear in the HPE 'Smart Array Controller' app or when i do a hard drive diagnostics from BIOS. I also tried all 8 slots on the backplane.

Could the issue be that the hard drive is brand new and a large 5TB?
Or perhaps the 8SFF backplane i have is fauly, how could i diagnose that?

Please see the image included below for more information on what i'm seeing in each mode:


Re: ML350 Gen9 8SFF drive cage, SATA HDD drive not visible



Thank you for the Post.


Upon checking the Quickspecs of the Controller B140i :



  • Up to 40TB of total internal storage with 10 x 4TB LFF SATA hard drives

  • Up to 10TB of total internal storage 10x 1.0TB SFF SATA hard drives


And also the Drives looks not HPE Drives, this could be one reason.


To isolate between Drives or the Backplane, you can try the below : 

1) Use different Drives on these Bays and check if the Bays are working fine.

2) Use any Drives lesser than 1TB to check.


If the different Drives works here, that confirms the Backplane is good.

If else it could be Backplane issue.


Also if you have any different Array Controller try enabling the additional Controller and check.


Thank you


I work for HPE

Accept or Kudo


Re: ML350 Gen9 8SFF drive cage, SATA HDD drive not visible

I can't believe this but i had the SAS data cables plugged into the back of the 8SFF backplane in upside down. They do fit the wrong way up so that's something to check if anybody has the same issue. I can confirm that the 5TB drives are now showing in both RAID with the B140i controller and AHCI modes.

Thanks for the help!