ProLiant Servers (ML,DL,SL)
cancel
Showing results for 
Search instead for 
Did you mean: 

ML350 Gen9 - NMI error when installing PCIe device

 
SOLVED
Go to solution
PhilippM
Occasional Contributor

ML350 Gen9 - NMI error when installing PCIe device

Hello,

 

we have installed our new ML350 Gen9 server and want to reuse the FC HBA from our old server (DL385 G2).

The product number of the PCIe HBA is ae312 - 60001. It's a Qlogic HBA.

 

I have tried all PCI slots (1 to 4 since we have only one CPU installed) and the server does either not recognize the card or it doesn't boot and displays an NMI error: "x64 Exception Type 02 - NMI detected..."

 

As the PCIe card is really old I wanted to ask if it's just not supported or if we can do anything to make it work?

 

Regards,

Philipp

 

 

 

3 REPLIES
Highlighted
lholling
Occasional Advisor
Solution

Re: ML350 Gen9 - NMI error when installing PCIe device

Hi PhilippM

 

The HP ProLiant Gen9 Servers actually have two modes in BIOS now UEFI and Legacy.

 

While the card is not officially supported in the Server if you change the BIOS Boot to Legacy (if you have an OS installed or are only using the B140i the server will most likely no longer boot up).

 

In order to have this card work, you should upgrade the Card to the latest BIOS available which is available from the following url

 

http://h20565.www2.hp.com/hpsc/swd/public/readIndex?sp4ts.oid=5246576&lang=en&cc=us

 

With both of these done then it should work, you may have to upgrade the BIOS of the card while it is located in the old server if the card is not detected while the Gen9 server is in Legacy mode. 

 

Once the card is working you will NOT be able to switch back to UEFI mode it must stay in Legacy mode for that card to work.

 

Leonard...

I am an HP employee.
PhilippM
Occasional Contributor

Re: ML350 Gen9 - NMI error when installing PCIe device

Hi Leonard,

 

thanks for the info!

Unfortunately we have already installed the OS in UEFI mode on a disk larger than 2 TB. Now it’s up to the customer to decide whether to do a new installation or buy a new FC card.

 

Regards,

Philipp

RDSR2k
Occasional Collector

Re: ML350 Gen9 - NMI error when installing PCIe device

There is another option.  I encountered this same error when Installing Kaspersky Endpoint Security on an HP Proliant ML150 Gen9.  I found an a fix on their forums.  Their support was little help with this issue but this worked for me on three different servers w/ the same issue.

This is a copy form the forum post (NOTE: There was a link but I  deleted due to some policies regarding URL posts)

"For future reference, the error i had was NMI_HARDWARE_FAILURE in hal.dll.
After translating it the solution was to run bcdedit /set x2apicpolicy disable in a command prompt and reboot."

After running the CMD, it fixed the NMI error I was getting and Kaspersky ran fine from that point forward.