ProLiant Servers (ML,DL,SL)
cancel
Showing results for 
Search instead for 
Did you mean: 

ML350 - SCSI Array card error

stingerman_1
Occasional Contributor

ML350 - SCSI Array card error

I have an ML350 server that just had the motherboard, SCSI card, SCSI cable, and drive cage replaced. We are still seeing the exact same error on post as when we did before replacing the parts. Can someone take a peek at the diagnostic file and tell me if you can make any sense of it? Unfortenately I don't have the exact error message as I am writing this, but I could get it tomorrow and post back. Your help would be much appreciated.
4 REPLIES
Andrew Young_2
Honored Contributor

Re: ML350 - SCSI Array card error

Hi.

Judging by the symptoms and the errors reported, plus the fact that the error condition continues despite the fact that the components have been changed I would think the problem then lies with one of the drives putting an error condition on the bus, maybe a short or a termination problem. Try to boot the machine with just one of the disks at a time to see which one generates the error.

It may also help to check that you are getting power to the drive cage.

HTH

Andrew Y
Si hoc legere scis, nimis eruditionis habes
Andrew Young_2
Honored Contributor

Re: ML350 - SCSI Array card error

Hi.

I have now taken a close look at the diagnostics. How many drives are there in the cage?

The controller identifies only three drives (36Gb 15K RPM) on bus 2, but says there are 2 logical drives each configured as RAID 5.

The drives are all reporting that they are fine. As far as my earlier post is concerend I still think there may be an intermittant error on one of the drive connectors which may show up as a bus and not a drive error.

Disregard my thoughts about power as in this case I don't think its the issue.

HTH

Andrew Y
Si hoc legere scis, nimis eruditionis habes
KMullins
Frequent Advisor

Re: ML350 - SCSI Array card error

Looking at the Adu report
He has 3 drives all BF03688284 with FW: HPB2

Two logical drives spread on the 3 drives
Smart Array 642
Controller FW
ROM Revision 2.76 ( resolved the following issue : may result in the bus down-shifting from Ultra 320 to Ultra 3.)

Error messages at post :
SLOT 5 Smart Array 642 Controller
Storage enclosure on SCSI bus 2 - Wide SCSI transfer failed.

SOLUTION: This may indicate a bad SCSI cable on bus 2. Try replacing this cable.

Disks themselves seem to be okay they are all login the same errors
SCSI Bus Parity Error Detected

However if there is bad parity data on one disk this will can be copied to the other diks..

Synchronous (fast/ultra) SCSI transfer is enabled. Drive is wide, but fw reverted to narrow

If the MB/Contr/Cable/Cage have been replaced in this server i would say to update the firmware of the hard drives to the latest version HPB5

http://h18007.www1.hp.com/support/files/storage/us/download/26451.html

What bios version is on the server itself?
Also check the cable coming from the array controller to the drive cage that is seated correct and also for bent pins on the drive cage/array controller eventough it has been replaced.
stingerman_1
Occasional Contributor

Re: ML350 - SCSI Array card error

Thank you all for your responses. I will try the suggested changes you have outlined and post back as soon as I am able.