ProLiant Servers (ML,DL,SL)
cancel
Showing results for 
Search instead for 
Did you mean: 

ML370 G2 won't boot with SmartArray 532 controller

Jase_DK
Occasional Visitor

ML370 G2 won't boot with SmartArray 532 controller

A few days ago our ML370 G2 suddenly refused to boot on our RAID 5 array (SA 532). It reported a parity error and claimed that the disk was a non-system disk.

I was not present at the office so my colleagues called a Compaq tech. The tech first replaced the SA 532 controller, but this did not help. Afterwards he replaced the motherboard which did not help either as the machine now locked up after scanning the SA 532. Sometimes it just stops after the scan, and sometimes it displays the message "17xx-controller in lock up state, disabled until problem is fixed" (or something like that).

I have tried updating the system BIOS and the firmware of the SA 532, however it does not help. I have also tried to move the SA 532 to our older ML350, where it works OK.

Any ideas what could be wrong?

Thanks.

Jakob Seedorff
10 REPLIES
Martin Breidenbach
Honored Contributor

Re: ML370 G2 won't boot with SmartArray 532 controller

And what did the Compaq tech say ? What will they do ?

Do you get these error messages/problems also when you disconnect the SCSI cable from the SA532 controller ?

If not then there might be a problem with the SCSI cable, drive cage backplane or a drive.

Check the SCSI cable for visible damage.

I've seen cases where a bad drive did lock the SCSI bus and other drives didn't work until the bad drive was removed.
Martin Breidenbach
Honored Contributor

Re: ML370 G2 won't boot with SmartArray 532 controller

BTW after replacing motherboard and SA controller the SA controller must be configured as boot controller (but that doesn't seem to be the problem here)
leo_43
Occasional Visitor

Re: ML370 G2 won't boot with SmartArray 532 controller

We got the same problem too. The ML370 G2 fail to start again after applied some patches to NT4 server OS. The following error was reported:

"SCSI BIOS not installed!
Slot2 Compaq smart Array 532 controller
17xx-controller in lockup state
(controller is disabled until this problem is resolved)"

any idea and how to solve that problem finally??

thanks
N.ANAND KUMAR
Occasional Advisor

Re: ML370 G2 won't boot with SmartArray 532 controller

Hi jakob,

Have you tried these options

Re-configuring NVRAM will resolve the issue
The RBSU has some differences... in order to clear NVRM
1.Press F9
2.Select Advanced Options
3 Select Defaults and Exit

Regards
anand
James P. Tango
Occasional Visitor

Re: ML370 G2 won't boot with SmartArray 532 controller

What are the default settings????
HGN
Honored Contributor

Re: ML370 G2 won't boot with SmartArray 532 controller

Hi

Make a note of the setting currently and then select the default settings and save it, later you can change the settings as per what you have.

Rgds

HGN

Re: ML370 G2 won't boot with SmartArray 532 controller

I had the same problem with a DL380 G2. I removed all of the hard drives, powered the system up and the Smart Array was fine. I then, thinking it may have been a bad drive or possibly a port a drive was in, replaced the drives one by one.

Currently everything is fine, but I haven't had to restart the system in some time.

I still don't understand what could be wrong. Maybe a bad firmware version?? I haven't been brave enouogh to test that.
Oleg Koroz
Honored Contributor

Re: ML370 G2 won't boot with SmartArray 532 controller

Remove every SCSI cable from 532 Controller and from SCSI on Board, remove every PCI card except 532 enable System CMOS switch settings at System Maintenance box (keep it ON), cycle system and move around 532 controllers between each slot if problem still exist, possibly system board problem.
David Heuser
Occasional Visitor

Re: ML370 G2 won't boot with SmartArray 532 controller

Today we´ve got the same problem. After installing the newest windows update ;-( I tried to reboot our ML370G2 with an integrated SA5i but this failed with the message 17xx Controller is in lock up state and disabled until changed. First I switched off the server and tried to restart it several times without success.
I pulled out the power cords, waited some minutes and tried it again, again without success. I disconnected the harddisk bay and the scsi cable, nothing. After this, nearly with tears in my eyes, I pulled out the SA5i switched off the machine and pulled out the power cord for about 30 minutes. I reassembled the stuff switched on the server and what wonder, the controller began to start its harddrives and everything was ok. But it still don´t know why this happens, perhaps the server bios and/or sa firmwire is bugg
Ben Podoll
Occasional Visitor

Re: ML370 G2 won't boot with SmartArray 532 controller

Hi,
I ran into this problem too, and all it means is that the locking portion of the case (that little thingy that flips down to lock in the PCI card) isn't all the way down. In my case the flip down thingy wasn't making the connection so the server knew it was down. If you don't believe me you can look on the server and see that there is a light on for each PCI slot on most servers (like DL580) and if it isn't locked down the light isn't on.
~Ben