HPE Community read-only access December 15, 2018
This is a maintenance upgrade. You will be able to read articles and posts, but not post or reply.
Hours:
Dec 15, 4:00 am to 10:00 am UTC
Dec 14, 10:00 pm CST to Dec 15, 4:00 am CST
Dec 14, 8:00 pm PST to Dec 15, 2:00 am PST
ProLiant Servers (ML,DL,SL)
cancel
Showing results for 
Search instead for 
Did you mean: 

ML370 G4 Serial ports

 
Jean-Pierre Radley
Occasional Advisor

ML370 G4 Serial ports

I am running SCO Openserver 6.0.0 on an ML370 G4.

While both show in the BIOS as enabled, the OS only sees the first one.

But I can't even use that one, either with a modem, or with a null-modem to a terminal. Nothing I type seems to go through the port.

Are there anyu special tips or tricks about the machines COMA and COMB?
2 REPLIES
ramesh_naik_
Esteemed Contributor

Re: ML370 G4 Serial ports

Hi Jean-Pierre,

Serial ports are not configured by default.

So give this a try!!!!

Use the following steps to enable serial ports (COM1 & COM2) /* configured on ML370 G4 running UW7.1.4: */
1. scoadmin -> Hardware -> Serial Manager
2. In the list of 'Configured serial ports (for iasy) on [HOSTNAME]:' select the COM port to be configured by highlighting it and pressing space bar. Then press tab and select 'Port' -> Modify . . . to open 'Modify Serial Port: term/##' window.
3. In 'Modify Serial Port: term/##' window, select the following:
a. Port type: In the drop down list, select 'COM # hardware flow control'
b. Configure port: select < * > incoming and outgoing
c. Speed (bps): In the drop down list, select 'auto'
d. Advanced Options:
i. Port settings . . .
1. Data bits: 8
2. Parity : None
Press tab and highlight [OK] and press Enter to save the settings.
ii. Receive buffer . . .: Use the default setting of 8 and exit after saving the setting.
After setting all the above options, exit 'Modify Serial Port: term/##' window. You should see corresponding 'COM' port being enabled.
If COM 2 (COM B) on ML370 G4 is disabled in RBSU, it will not be listed under 'Configured serial ports (for iasy) on '.
Enable that port in RBSU and follow the information provided at [HTTP: calderasystems.com products clustering ReliantHA hainstal.html#haRaI.install.hw] to enable COM 2 in the OS and subsequently follow the steps given above (to enable COM 1) to enable COM 2.


Hope it works!!!!!


Regards
rmn
Jean-Pierre Radley
Occasional Advisor

Re: ML370 G4 Serial ports

rmn:

I am not running UnixWare.r
I am running OSR 6.

I'll repeat: both ports show as enabled in the BIOS, but 'scoadmin serial' or 'resmgr' only list the first one.

And I can't even use that one.

I'll add this: I have NO problem running both serial ports with the same OS on a white box.

No only am I not a novice at serial comms, I wrote the 'xc' communications program, which is a superior replacement for 'cu'.