ProLiant Servers (ML,DL,SL)
cancel
Showing results for 
Search instead for 
Did you mean: 

ML370 G6 networking card (NetXen NX3031) doesn't support Debian 7.0 Wheezy

mdesantis
Occasional Collector

ML370 G6 networking card (NetXen NX3031) doesn't support Debian 7.0 Wheezy

I recently upgraded to Debian Wheezy, but using the wheezy kernel (3.2) I can't see any network interface, while with the Squeeze kernel (2.6) I see eth0. It doesn't work neither with the squeeze backports (3.2) kernel.

 

I tried to reinstall firmware-netxen and install the experimental and unstable versions (0.37 and 0.38 versions, respectively), but none of them seem to work.

 

Currently the server is online with the squeeze kernel, but in this way I can't upgrade the kernel, which is a security flaw. Do you have some suggestions?

 

Thank you

2 REPLIES
mdesantis
Occasional Collector

Re: ML370 G6 networking card (NetXen NX3031) doesn't support Debian 7.0 Wheezy

This is the output of dmesg | grep firm:

 

$ dmesg | grep firm
[    1.310432] GHES: APEI firmware first mode is enabled by WHEA _OSC.
[    1.505572] netxen_nic 0000:06:00.0: Flash fw[4.0.406] is < min fw supported[4.0.505]. Please update firmware on flash
[    1.506398] netxen_nic 0000:06:00.1: Flash fw[4.0.406] is < min fw supported[4.0.505]. Please update firmware on flash
[    1.507002] netxen_nic 0000:06:00.2: Flash fw[4.0.406] is < min fw supported[4.0.505]. Please update firmware on flash
[    1.509284] netxen_nic 0000:06:00.3: Flash fw[4.0.406] is < min fw supported[4.0.505]. Please update firmware on flash
[    7.048707] platform radeon_cp.0: firmware: agent aborted loading radeon/R100_cp.bin (not found?)
[    7.048825] [drm:r100_cp_init] *ERROR* Failed to load firmware!

ditwal001
Occasional Visitor

Re: ML370 G6 networking card (NetXen NX3031) doesn't support Debian 7.0 Wheezy

Hi,

 

I need to upgrade a old HP DL 160 G5 with an 10GB card. The only compatible one is a NX3031. I am wondering if you gave it a try to compile a new Kernel like 3.10.7 enabling the netxen modules?

 

Since a while past, did you get it to run now?

 

Would be cool to hear smt from you,

 

Walter.