ProLiant Servers (ML,DL,SL)
cancel
Showing results for 
Search instead for 
Did you mean: 

ML370 Memory upgrade

Ben Bramwell
Advisor

ML370 Memory upgrade

I've purchased 2 compaq 1GB memory upgrades (total of 4 512MB chips). After replacing the old chips and booting the system I get several different blue screens (running windows 2000). The blue screens have ranged from strange memory errors to errors about not being able to load registry hives. I'm thinking I have bad ram but is there anything other then swapping the ram out that I need to do on an ml370 to get it to upgarde (it shows up at the boot screen as 2GB correctly)? I can put the old ram back and everything boots fine also.
8 REPLIES
Oleg Koroz
Honored Contributor
Oleg Koroz
Honored Contributor

Re: ML370 Memory upgrade

sorry missed "2 compaq 1GB " verify just specs does it work with one pair ?
Ben Bramwell
Advisor

Re: ML370 Memory upgrade

The memory I have are 4 512MB, Sync, 133MHz, CL3, ECC, REG. The model number on the chip though is 127006-041. This was bought from a third party and was listed to work with the ML370. When I search HPs site I'm seeing now it might be for the ml330. All the specs look right to work in the ML370 though.

It also works fine as long as I only use 2 sticks (1GB total). I have a total of 6 sticks and have tried several combinations of 4 and everytime now I get a memory parity error when I boot. Is this ram just not going to work in this server?
Oleg Koroz
Honored Contributor

Re: ML370 Memory upgrade

127006-041 ASSY (159227-001 SPN) right part number for ML370, 512-MB, 133-MHz, registered SDRAM dual inline memory module
Server should not have any problem with Maximum memory capacity is 4 GB.

Identify which pair faulty(identify after which module is bad from Pair), test one at time, you might have DIMM socket Problem, make sure system ROM Up to date. Do F10 for Hardware Scan and Changes see if that helps. If you ok and you known how to Restore Acsess to system Partition you can clear NVRAM.

=at what Point exactly you get parity error ?



Oleg Koroz
Honored Contributor

Re: ML370 Memory upgrade

127006-041 ASSY (159227-001 SPN) right part number for ML370, 512-MB, 133-MHz, registered SDRAM dual inline memory module
Server should not have any problem with Maximum memory capacity is 4 GB.

Identify which pair faulty(identify after which module is bad from Pair), test one at time, you might have DIMM socket Problem, make sure system ROM Up to date. Do F10 for Hardware Scan and Changes see if that helps. If you ok and you known how to Restore Acsess to system Partition you can clear NVRAM.

what what Point exactly you get parity error ?



Ben Bramwell
Advisor

Re: ML370 Memory upgrade

It might not matter but the model number I listed is actually for the ML370 G2, I'm on a ML370 G1. I've got the company replacing the part and will see if that fixes it. None of the memory modules do it individually only when there are 4 in there.

Right after the windows 2000 loading screen gets done loading with the bar going across the screen constantly is when this happen.
Ben Bramwell
Advisor

Re: ML370 Memory upgrade

Just to follow up on this. It looks like I have a bad RAM socket which caused my problems.
Ben Bramwell
Advisor

Re: ML370 Memory upgrade

Okay so some more information on this again. I'm still trying to figure out what is going on here.

I can take the 4 ram sticks and put them in another ml370. It boots fine. I can run memtest on it and nothing comes back with errors.

I install the same 4 ram chips back into this server and it wont boot because of a bsod from windows as it boots because of a parity error. I then boot memtest off of cd and it comes back with errors from memory 1071 - 2045mb. At this point I pull all but 1 ram stick and boot memtest and it runs fine. I do this for every ram slot and it works fine. I add a second ram stick and test all slot combinations and everything works. Then I add a 3rd memory stick and test all combinations and memtest gives me no errors. So I'm really at a loss here. Basically I have ram installed in slots 1,3,4 right now (installing 1,2,3 also gives me windows bsod about ram parity) and it runs okay but about once every week it bsods with memory parity error. Anyone have any ideas other then the mobo is going bad or slots 3 and 4 possibly because the ram test comes back with errors on the upper half of memory?