ProLiant Servers (ML,DL,SL)
Showing results for 
Search instead for 
Did you mean: 

Max Dirty Cache Lines Not Flushed Reached - Warning

Go to solution
Occasional Visitor

Max Dirty Cache Lines Not Flushed Reached - Warning

Set up a brand new Proliant ML350 with SA P410i Controller with 256MB Cache, no battery.  Single RAID1 array. Running Win Svr 2008 R2.


The Array Configuration Utility is reporting the following:


"A cache error was detected. Run a diagnostic report for more information."


The Diagnostic report shows the following Warning:


"Max Dirty Cache Lines Not Flushed Reached" 


Is this warning critical?  If yes, what is solution to fix the problem?  Other than this, the server is running fine.



Johan Guldmyr
Honored Contributor

Re: Max Dirty Cache Lines Not Flushed Reached - Warning

Hi, hm.. firmware upgrade?

If the cache module can be reseated, that might help.
Have you rebooted the machine as well?

ADU might be able to give you some more information.
Occasional Visitor

Re: Max Dirty Cache Lines Not Flushed Reached - Warning

Rebooted and reseated cache.....but message still there.


Thanks for the reply.

Honored Contributor

Re: Max Dirty Cache Lines Not Flushed Reached - Warning



Try to change the percent of the read/write cache in ACU. For example 25% to 75% .



How to Say Thank You? Just click the KUDOS!
Occasional Visitor

Re: Max Dirty Cache Lines Not Flushed Reached - Warning

Changed the read/write ratio to 75/25 and the message went away.  Previous setting was 100/0 and i don't have a battery backup for the cache.



Frequent Visitor

Re: Max Dirty Cache Lines Not Flushed Reached - Warning

From where and How do I change these settings?  Please help me I am newbie in handling servers.  To brief about my situation:  I had 256 Cache and needed to Expand my existing RAID 5 by adding one / two HDD 2 x 300GB.  At, they informed me that I need 512 BBWC to accomplish the task.  We have finally replace the 256 Cache with 512.  It shows me the very same error:  Cache error detected.  Run HP Diagnostic report ******.


I appreciate you effort about helping others responding in forums


For your Reference I am attaching ADU Report.


Please Help.

Donald J Wood
Frequent Advisor

Re: Max Dirty Cache Lines Not Flushed Reached - Warning

I know this thread is old.. Just wanted to say that this issue is still occuring. I had opened a case with HP about it too and nobdy could explain what happen. Here's my senario.

I have several DL380G7 server running ESXI 5.x. Each have the P410I controller with Firmware Version: 6.62. One day I came to work and level1 pings me with a ticket stating that they're getting alerts on some of the WIndows servers virtual machines which indicate disk latency. I spend about an hour or so looking through vCenter and I find nothing. So I decide to dig a little bit deeper and run a /opt/hp/hpssacli/bin/hpssacli ctrl all show detail. That's when I see the message "A cache error was detected. Run a diagnostic report for more information."  I strarted looking around and to make a long story short, I found 6 other DL380G7 servers with the same error. History indicated that all of these had a drive replaced in the distributed data guarding in the past 90 days. Opening a case with support one and escalting it to level2 only got me the "Try this Firmware" statement. Therefore HP either hasn't been able to root cause this issue or doesn't understand why it's happening. Seems this has been a problem for close to 6 years now. 

Here's what I do know.

  1. Each server has had a Drive failure in the past 90 days.
  2. If you try to modify the cache read/write ratio, the cache will go to temp disabled.
  3. Reboot clear the temp disabled and the cache error.
  4. One unit had a drive failure directly after noticing the "cache error". 

My conclusion here, I don't think this is a firmware issue. I think this cache error is being creating due to drive hardware problems, possibly when a secotor goes bad and does a hotfix. to the rediection area of the disk. I can't prove this because due to the limitation of the ESXI OS and the ILO, you can't see the drive counters like you can when you had a SMHP.

Below is the specification of one of the units

Smart Arrray P410i in Slot 0 (Embedded)
Bus Interface: PCI
Slot: 0
Serial Number: xxxxxxxxxxxxxxxxxxxxxx
Cache Serial Number: xxxxxxxxxxxxxxxxxxxx
RAID 6 (ADG) Status: Disabled
Controller Status: OK
Hardware Revision: C
Firmware Version: 6.62
Rebuild Priority: Medium
Expand Priority: Medium
Surface Scan Delay: 15 secs
Surface Scan Mode: Idle
Queue Depth: Automatic
Monitor and Performance Delay: 60 min
Elevator Sort: Enabled
Degraded Performance Optimization: Disabled
Inconsistency Repair Policy: Disabled
Wait for Cache Room: Disabled
Surface Analysis Inconsistency Notification: Disabled
Post Prompt Timeout: 0 secs
Cache Board Present: True
Cache Status: OK
Cache Ratio: 25% Read / 75% Write
Drive Write Cache: Disabled
Total Cache Size: 512 MB
Total Cache Memory Available: 400 MB
No-Battery Write Cache: Disabled
Cache Backup Power Source: Batteries
Battery/Capacitor Count: 1
Battery/Capacitor Status: OK
SATA NCQ Supported: True
Number of Ports: 2 Internal only
Encryption Supported: False
Driver Name: HP HPSA
Driver Version: 0.0.0
Driver Supports HP SSD Smart Path: Fals

Smart Array P410i in Slot 0 (Embedded)
Controller Status: OK
Cache Status: OK
Battery/Capacitor Status: OK

smart Array P410i in Slot 0 (Embedded)

array A

logicaldrive 1 (279.4 GB, RAID 1, OK)

array B

logicaldrive 2 (10.6 TB, RAID 5, OK)