ProLiant Servers (ML,DL,SL)
cancel
Showing results for 
Search instead for 
Did you mean: 

Memory Interleaving on ML350 G4

Wayne Rasmussen
Occasional Visitor

Memory Interleaving on ML350 G4

I have installed 4 x 1GB PC2700 ECC memory modules in a ML350 G4 (HP memory, part number 358348-B21) - memory is seen by O/S. Based on what I have read I would expect Interleaving to be activated yet Insight Manager Diagnostics indicate that interleaving is "Not supported", memory throughput tests collaborate this (MEMTEST 3.1 indicates 1.8+GB throughput). I checked the details on the memory and arranged them in pairs with same manufacturing date and that did not change the situation. I currently assume that since they were not "matched pairs" in A or B banks even though they are the same part numbers; that information in the SPD is causing interleaving to be disabled. If that was so, though, I would expected to see Interleaving supported but not active (OFF)!

Does anyone know of a switch, jumper, or BIOS option that may be overriding BIOS Interleaving activation or is it related to SPD data?

It is perplexing since the HP doco (QuickSpecs HP Proliant ML350 Generation 4(G4)) I am looking at indicates "All memory kits are single DIMM kits" yet it also states "The HP Proliant ML350 G4 requires memory interleaving when more than one DIMM is installed."

Regards

Wayne
1 REPLY
Brian_Murdoch
Honored Contributor

Re: Memory Interleaving on ML350 G4

Hi Wayne,

I agree that you should have interleaving enabled providing the dimm banks have identical dimms in them. The attached document gives further information regarding the ML350G4 supported memory configurations and you do appear to have purchased the correct optional dimm kits.

Some Proliants have many advanced settings in the BIOS (Press F9 when prompted at POST) but I'm not sure if the interleaving is changeable as it appears to be something which is detected by the system board logic in this case. You can have a look however in the "Advanced" section of the BIOS and see if interleaving can be disabled (if available as an option).

I hope this helps.

Brian