ProLiant Servers (ML,DL,SL)
cancel
Showing results for 
Search instead for 
Did you mean: 

Mgt Agents 5.20 turns server into zombie

Ayman Altounji
Valued Contributor

Mgt Agents 5.20 turns server into zombie

I have an ML370 (P17) with a 3200 controller (four BD01862376
drives in one RAID 5 array) and an internal DLT 35/70 hanging off SCSI. All ROM BIOSes are up to date (as of 18 Oct 01).

I hit trouble installing the new versions of the Management agents (from v5.00a to v5.20a) using Compaq Support Pack 1 for Netware (v1.04a). I let CPQDPLOY.NLM try to install all patches, as is the default option. CPQPOWER.NLM puked then, when it got to the Mgt Agents, it hung the console attempting to unload CPQWEBAG.NLM. I never load this so CPQSP4x must have done it for me. I checked CPQSNMP.NCF afterwards and found it had made a mess of the file at the bottom, with unnecessary blank lines and things hashed out and in the wtong place, etc.

The hang on "unload CPQWEBAG" happens every time I try to run the agent installs from CPQSP4x.

Since all of this happened, I have only got the server to be stable by making sure CPQSNMP.NCF does not run. If it does run, a simple way to make the server a zombie is "load install".

My guess... either v6.36 (upgrade from v5.70) of N100.LAN has screwed up or it's one of the management agent NLMs, most probably CPQWEBAG or CPQDASA (again!).

P.S. A 5500 is also exhibiting stranger symptoms. This and the ML370 are the only 2 servers I have tried the new agents on!

Help anyone?

James Nash
Middlesex University, UK.
5 REPLIES
Ayman Altounji
Valued Contributor

Re: Mgt Agents 5.20 turns server into zombie

I am having the exact same issue. Looks like ther might be something wrong with this release. Anybody find a fix yet?

Scott Smith
Ayman Altounji
Valued Contributor

Re: Mgt Agents 5.20 turns server into zombie

Still no luck in fixing the problem.

I think I have proved that the problem occurs after you do a CQMGHOST v5.20 upgrade (from 4.90 at least). Unloading CPQWEBAG.NLM causes server zombie mode and/or console loss. I have more details if they are required.

Anyone from Compaq care to chip in?
Ayman Altounji
Valued Contributor

Re: Mgt Agents 5.20 turns server into zombie

We have 11 net ware servers and have installed the latest agents on all our servers running net ware service pack 3/ the same issues are happening with us BUT only on the ml370 compaq server model all the others dl380/dl580 are working fine with the new agents/ have posted a note to compaq but have had no reply as yet
Ayman Altounji
Valued Contributor

Re: Mgt Agents 5.20 turns server into zombie

We also have a mix of ML370s and a 3000. We have Novell 5.1, SP3 and were running 5.00 agents beautifully. That was until we loaded the 1.04a updates. Then all hell broke loose. It took us over 6 hours to narrow the field down to what looks like the CPQSNMP.NLM and CPQBSSA.NLM. We couldn't even downgrade the agents to 1.03a or even reinstall the NSSD to 4.90 agents. What a joke!!! The only way we could stabilize our servers was by completly disable any form of SNMP management on the servers. Totally unacceptable!!! And here is one for the books. Since the problems began, all the servers are running below 75% on their long term cache hits. Some as bad as 50%. Not good.

Anybody have any luck getting their servers back on track?

Cheers!

Matthew Puckett
Network Engineer - TDOT
Ayman Altounji
Valued Contributor

Re: Mgt Agents 5.20 turns server into zombie

This was my reply from compaq :

From: CVOMPAQ eServices

Hello Duncan,

We have seen issues using drivers from SmartStart 5.20, where the server lockups when
CPQSCSA.NLM loads. The recommended fix for this is to use the drivers from Smartstart
5.10 or 5.3. Thank You, COMPAQ eServices

P.S there are no drivers i.e ver 5.3 yet availiable (good luck to all)