ProLiant Servers (ML,DL,SL)
cancel
Showing results for 
Search instead for 
Did you mean: 

Missing space in RAID 5 array

D_London
Occasional Visitor

Missing space in RAID 5 array

I'm probably going to walk away from this with a red face but I can't puzzle it out.

 

I have a new DL380G7 with 4x 1TB SAS drives; RAID 5, no spare (I know).

 

I'd have expected 3x 1TB = 3TB of space in my logical drive and that amount useable for my partitions but I only have 2.35TB of space for my OS.

 

Can I lose 0.5TB just from the big stripe size? That was the unattended default settings the P410i makes - I didn't SmartStart this box as I was putting Server2012 on it.

 

More Information -
Logical Drive 1 (2.7 TB, RAID 5) 
Logical Drive Status OK
Drive Number 1 Drive Unique ID 600508B1001C451D293A25D0F4F57C17 Size 2861512 MB
Fault Tolerance RAID 5
Heads 255 Sectors/Track 32 Cylinders 65535
Strip Size 256 KB
Full Stripe Size 768 KB
Caching Enabled
Parity Initialization Status Initialization Completed
Disk Name \\.\PhysicalDrive0
Disk Partition Information
Partition Number: 1, Size: 350 MB, Mount Point: Unknown
Partition Number: 2, Size: 2.0 TB, Mount Point: C:\ 
Array Status OK Array A Drive Type SAS Used Space 3.6 TB (100%)
Total Usable Space 3.6 TB 
Spare Drives  None 
Failed Drives  None  
 
 

P.S. This thread has been moved from ProLiant Storage Systems to ProLiant Servers (ML,DL,SL). -HP Forum Moderator

5 REPLIES
Johan Guldmyr
Honored Contributor

Re: Missing space in RAID 5 array

Does the OS only see the disk as 2.35TB? Or do you mean after formatting/partitioning you only have 2.35TB?

D_London
Occasional Visitor

Re: Missing space in RAID 5 array

The OS sees 2.35TB space and auto allocates 350MB to the boot partition and 2.0TB to the C: partition. Neither partition can be expanded and available space is 0.

 

So I start with 4x 1TB drives.

The ACU shows an array with 3.7TB, no spares.

That gives me a 2.7TB RAID5 logical drive.

Disk management in Server2012 recognises the HP Logical Volume and sizes it as 2.73TB, and that all capacity is allocated.

 

400GB seems a lot to lose to a 1000/1024 issue on what a thousand means. I'd understand a 2% difference in the numbers but this is a lot more.

 

I still think I'm missing the point here, rather than it being a fault!

 

D_London
Occasional Visitor

Re: Missing space in RAID 5 array

To compare things I used a single Server 2012 Server Manager console.

 

A Dell box I have in the group, also running RAID5, shows the RAID type disk as capacity 1.80TB and adding up the volumes (which show no unallocated space) gives me a total of 1.80TB. No magical overhead.

 

Using the same console it shows this HP server with a RAID type disk as capacity 2.73TB, but adding up the volumes (which show no unallocated space) gives me a total of 2.0TB.

 

That is close to what I'd expect if I was running this on RAID6 with the extra parity disk.

k_romych
Established Member

Re: Missing space in RAID 5 array

Got the same issue : /

I have an HP ML35 350 G6 with Smart Array P410i.

It had 4 active drives and 1 spare 279Gb each - making 838 G logical drive. I have added another drive and added it to the raid so there are 5 x 279 Gb drives in the raid. It has synced but logical drive still showing only 838 Gb size in HP System Manager, when it should be around  now1116Gb.

Any ideas? HP?

waaronb
Respected Contributor

Re: Missing space in RAID 5 array

You probably need to start a new topic.  I don't think your problem is related to the original question.

 

I think the original problem is because an MBR disk has a maximum boot partition of 2TB.  To go beyond that would require a UEFI system and GPT, but the Gen9 boxes are the first Proliants to support UEFI (I think... I don't have one yet).

 

To add 4 x 1TB drives in a RAID 5, which is 3 TB (let's ignore the different between 1024 and 1000), you would add them all to a single array and then carve out seperate logical volumes using the ACU.

 

The RBSU won't let you do that... it only creates one logical volume on the array, so you would have to boot from Smartstart/SPP and use the full ACU / SSA program to do that on the boot volume.  If it's a second array and not the boot, then you can do it using the Windows SSA utility since it's a secondary set of disks.

 

*Your* problem is probably that you added an extra disk and added it to your array, but did you do an expansion so your logical volumes are using the new space?

 

And once you've done that, you need to use your OS tools (just the Disk Manager in Windows) to extend your partition into the new unused space.