ProLiant Servers (ML,DL,SL)
cancel
Showing results for 
Search instead for 
Did you mean: 

NC7782 Teamed NICs Keep Losing IP Address

doug sutton_1
Occasional Contributor

NC7782 Teamed NICs Keep Losing IP Address

We currently have 2 Proliant DL360 G4 servers running Windows 2003 SP2 with 2 single port NC7782 network adapters. The driver version of both nics is 11.7.0.0 and the Network Configuration Utility is version 9.40.0.0.

Currently the nics are teamed with the following configuration: there are 2 switch ports configured for load balancing and the nic cards are teamed for "802.3ad Dynamic with Fault Tolerance" and the Transmit Load Balancing Method is set to "Destination IP Address". We are also getting 2gbps throughput on the teamed nics.

This configuration works well with no issues. Until the server is rebooted. Once the server comes back online, the primary teamed nic loses the static ip address assigned to it and looks for a dhcp address. DHCP is disabled in the properties of the teamed nics, however it is running as a Windows service. Does anyone have any idea as to why this is happening? Is there a setting we're missing or some configuration that's not right. Any help would be greatly appreciated as we are stumped!!

Thanks!
9 REPLIES
Lmm_1
Honored Contributor

Re: NC7782 Teamed NICs Keep Losing IP Address

It seems an old issue, if you make and ipconfig right after reboot, do you get 0.0.0.0? if so, thats a IP race condition, I´ve seen this issue with cisco switches only, more prevalent on 2000 or 3000 series, it seems to be a timing issue with the link, driver load, tcp/ip...etc. Can you confirm the quad 0?

If so, I´d recommend to change team mode to SLB, it will require an static channels instead of LACP, it will give you same 2Gb TX/RX

rgds,
lmm

gabep
Occasional Advisor

Re: NC7782 Teamed NICs Keep Losing IP Address

I am having the exact same problem, DL380G4, Win2003 x64, and Cisco 2950 switch.

Can you please give me some pointers how to fix this? All drivers are up to date.

(I also have a couple of DL380G3s running W2003 x86 with the same NIC teaming connected to the same switch and they are fine, no problems.)
Lmm_1
Honored Contributor

Re: NC7782 Teamed NICs Keep Losing IP Address

Are you seeing quad 0 after reboot?
gabep
Occasional Advisor

Re: NC7782 Teamed NICs Keep Losing IP Address

Yes I get 0.0.0.0.
Lmm_1
Honored Contributor

Re: NC7782 Teamed NICs Keep Losing IP Address

Have you tried using static channel on the cisco side? Channel group x mode on, the only solution is stay away of LACP.
gabep
Occasional Advisor

Re: NC7782 Teamed NICs Keep Losing IP Address

This is what I got on the switch on the two ports that the server is connected too:

interface FastEthernet0/12
switchport mode access
channel-group 2 mode active
spanning-tree portfast
interface FastEthernet0/13
switchport mode access
channel-group 2 mode active
spanning-tree portfast


What should I change?


Lmm_1
Honored Contributor

Re: NC7782 Teamed NICs Keep Losing IP Address

Assuming that team mode will be set to auto, the switch will look this way

interface FastEthernet0/12
switchport mode access
channel-group 2 mode on
spanning-tree portfast
interface FastEthernet0/13
switchport mode access
channel-group 2 mode on
spanning-tree portfast

The quad 0 shouldnt appear anymore and the team mode shoul go to SLB, it will give you same 2GB Tx/Rx
gabep
Occasional Advisor

Re: NC7782 Teamed NICs Keep Losing IP Address

I'll try this and report back. Thanks for the help!
gabep
Occasional Advisor

Re: NC7782 Teamed NICs Keep Losing IP Address

Just a confirmation, this has resolved our issue. Thanks again.