ProLiant Servers (ML,DL,SL)
cancel
Showing results for 
Search instead for 
Did you mean: 

Netware losing DOS partition

Nigel Holmes
Occasional Contributor

Netware losing DOS partition

I have a compaq ML310 with a smart controller and twice now, after a crash and a power failure (it was on UPS!), when the server rebooted the DOS partition has been lost or corrupt, needing a format and all files copying again.

It is Netware 6 SP3 and the latest compaq NSSD.

Has anyone else seen this / knows of a fix??

Thanks in advance for any help
8 REPLIES
Claude Boileau
Valued Contributor

Re: Netware losing DOS partition

Hi Nigel,

If you want to re install check out this help file in your recent smart start cd. in the folder called help their is a file called nwpreng.hlp. Once up check out the novell manual install option and it will give you the steps to follow. Including the dos portion.
Claude Boileau
Valued Contributor

Re: Netware losing DOS partition

Hi Nigel

If you need the dos driver for you cdrom:
sp 4282 is the one. Found at the ftp.compaq.com site under pub for the (id cdrom).

Regards
Nigel Holmes
Occasional Contributor

Re: Netware losing DOS partition

Claude,

Thanks for the reply.

I have been able to recreate the DOS partitions on both occassions and now have a boot diskette and CD combo that allow me to recreate the partition in minutes.

However, I should not be having to do this! I have been using Netware since 1990 and have not had this before!

So my question is more, is there something I should be doing at Compaq level to remove this problem, e.g. upgrade ROM levels, resetup in a different way etc.

Again, thanks for your reply I need all the help I can get on this one!

Nigel
Todd Jetzer
Occasional Visitor
nigel mcmahon
Occasional Visitor

Re: Netware losing DOS partition

I am having the same issue have outstanding calls with compaq.

are you running acrserve on this server.

have you update raid controller firmware new release issued on 11th june
Lee Abbott
Occasional Visitor

Re: Netware losing DOS partition

I have received the following email from HP, which seems to clarify the conclusions on Novell's discussion thread:

When attempt to access DOS partition of NetWare 5.1 or 6.0 server (usually by restarting the server for some reason), the DOS partition is inaccessible and the server will not boot. Prior to restarting, NetWare continues to function properly, but may have problems with real-mode access to the DOS partition from within the OS.
Symptoms
. The FAT table of the DOS partiton becomes corrupted which renders the partition inaccessible. Version of DOS in use is DR-DOS 7.02 which is set up during the NetWare install.
Cause
SmartStart 6.x modifies the partition boot sector on the DOS partition just prior to launching the NetWare install with the intent of making the drive bootable (similar to the DOS SYS command). Something during this process causes the CHS (cylinder/head/sector) information in the FAT16 boot record to become corrupted. This creates a lot of lost clusters and cross-linked files in the DOS partition. After a while, normal reads/writes to the DOS partition will step on a cross-linked or lost cluster, thereby resulting in corruption of the FAT table. Utilities such as Scandisk and/or CHKDSK will not fix this problem because of the incorrect CHS information in the boot sector.
NOTE: This problem only occurs on SmartStart-created DOS partitions of 1503 MB or higher. If the partition size is 1502 MB or less, this problem does not occur.
Resolution/Workaround
Smartstart 6.40 and later Assisted installs of Netware will create and format the DOS partition correctly.
When using Smartstart 6.0 - 6.3, this issue can be prevented/worked around in 1 of 2 ways:
1.If using SmartStart 6.0 - 6.3 to start a NetWare install, set the DOS partition size to 1502 MB or less. This issue does not occur unless the DOS partition is 1503 MB or greater.
2. Bypass SmartStart altogether and perform a manual installation of NetWare. If the DOS partition is created manually prior to or during the NetWare install, this issue does not occur. Remember that the maximum size DOS partition that NetWare 5.1 or 6.0 will support is 2048 MB (if manually created) or 1500 MB (if created as part of the native NetWare install process).
3. On a unit with NetWare 6.0, the DOS partition may be deleted and re-created if you have a working backup of the DOS partition. Please do not attempt this workaround on NetWare 5.1 units, as it may render NSS volumes inaccessible.

Nigel Holmes
Occasional Contributor

Re: Netware losing DOS partition

Just to say thank you to all who helped with this fault.

I look forward to Compaq producing a long term fix in the near future, meanwhile I shall use the tips enclosed as a work around

Thanks again

Nigel
Janine Bertolo
Honored Contributor

Re: Netware losing DOS partition

For those of you affected by this, the fix has been published at: http://h18023.www1.hp.com/support/files/server/us/download/18601.html

Janine
To get results you've never had before, try something you've never tried before.