ProLiant Servers (ML,DL,SL)
cancel
Showing results for 
Search instead for 
Did you mean: 

No LInk w/ DL360 G3 NIC and Cisco 6509 Switch

 
jcosta1
Occasional Contributor

No LInk w/ DL360 G3 NIC and Cisco 6509 Switch

Hello,

I'm seeing some strange things when I connect a DL360 G3's NC7781 NIC to a Cisco 6509's 100BaseT interface. If I set both to 100FD, and reboot the server, I loose the link. Note that auto or 100HD on both sides will work just fine. Also, in the case of reboot with 100FD set, I can see the link light turn on on both the NIC and the switch interface indicating an established link. It is only when the NIC driver loads, in Windows 2000, that the link breaks. I've verified the latest drivers. Also, not all servers do this. Could there be some NIC firmware issues?? Cisco verified that I'm running the most current IOS and also the switch's config.

I hope someone else has also seen this issue..


Thanks,

Jack
3 REPLIES
Chanler Childs
Frequent Advisor

Re: No LInk w/ DL360 G3 NIC and Cisco 6509 Switch

Just want to make sure you're using a known good cat 5 cable. Its sounding like one of the pairs used in duplex mode isn't connected properly.
jcosta1
Occasional Contributor

Re: No LInk w/ DL360 G3 NIC and Cisco 6509 Switch

Thanks for reply. Since posting this, I've done more research with Cisco. Looks like Cisco Cat 6509 IOS has bug related to auto MDIX sensing. This bug causes link to not establish when connecting to certain NICs, because the switch thinks the port should be set to MDIX (cross-over type connection) . I had already tried different CAT 5 cable to no avail. I did find that if I replace straight-through CAT 5 with cross-over CAT5 (two cross-overs = straight-through), the problem is gone. Cisco is having me upgrade the IOS to allow me to disable auto MDIX on 10/100 ports connected to servers as a work around. Sounds like they don't have a IOS fix yet.

Regards,

Jack
Egonle
Occasional Advisor

Re: No LInk w/ DL360 G3 NIC and Cisco 6509 Switch

HI,

could you please be more detailed on your current IOS version/hardware version of the switching module and how to name the IOS fix to get faster help by cisco.

Regards,
EE