ProLiant Servers (ML,DL,SL)
cancel
Showing results for 
Search instead for 
Did you mean: 

No disk detected during SLES 8.1 install

SOLVED
Go to solution
TIMOTHEE
Advisor

No disk detected during SLES 8.1 install

hello everybody

i have quiet a heavy problem here

i'm setting up a HP DL 380 G4 server with SuSE SLES 8.1. I first set up a disk array (HP SMart Array 6i) using ORCA (two disks with RAID 1). I then try to install SuSE but at the very beginning when it comes to probe the hardware YAST stops saying : "No hard disk were found : check your hardware).

I did the same on previous servers with Smart Array 5i and never encountered the problem.

Does SLES 8.1 have kernel support for Smart Array 6i by default ?
If not how can i somehow fix this ?

Any help is greatly appreciated

thanks a lot
14 REPLIES
Bryan Eley
Trusted Contributor

Re: No disk detected during SLES 8.1 install

Check out this link:

http://h18022.www1.hp.com/support/files/server/us/download/20796.html
I *THINK* your system is in the supported matrix.
See also:
http://developer.novell.com/yes/80532.htm

Hope this helps!
Bryan Eley
Trusted Contributor

Re: No disk detected during SLES 8.1 install

Sorry, I should have been more precise. I believe your system requires a driver module that the HP link I provided in the previous post addresses, and I imagine at some point during the initial install you will need to point the installation to your driver disk so that SLES will see the array controller.

Good luck!
Bryan
TIMOTHEE
Advisor

Re: No disk detected during SLES 8.1 install

thanks bryan

but unfortunately my G4 doesn't have any floppy plus the driver diskette has been set up for 2.4-21 kernel whereas mine is 2.4-19

thanks anyway

if you think of any other workaround let me know
Bryan Eley
Trusted Contributor

Re: No disk detected during SLES 8.1 install

Hmmm, 2.4-19, you say?


Well, http://h18004.www1.hp.com/support/files/server/us/download/20798.html has the rpm version that supports your kernel, but I imagine an rpm won't help you at install.

There are earlier revisions of the driver link I showed yesterday at http://h18023.www1.hp.com/support/files/storage/us/revision/7974.html. For example, clicking on the version 2.4.50-30 13 Sept. 2004 link version takes you to:
http://h18023.www1.hp.com/support/files/storage/us/download/22004.html which seems like it might support pre-SP3 version of SLES8. Assuming the driver is compatible, could you burn the driver to a CD?
TIMOTHEE
Advisor

Re: No disk detected during SLES 8.1 install

hello Bryan

burning it to a CD is one idea i didn't try for now for i still don't have the ISO image of SUSE SP3. I'm currently downloading it and then i'll try to load the module during the install process by using an external USB drive...if this fails for some reasons i'll try with a CD but i don't know if there's a particular procedure to respect to burn the CD, i imagine that can't just take the floppy content and put it on the CD just lie that, am i right ?

thanks a lot for your help, it's greatly appreciated

Bryan Eley
Trusted Contributor

Re: No disk detected during SLES 8.1 install

Yes, you should be able to put the drivers on a CD, if you don't have a floppy usb drive or the system doesn't recognize a floppy usb drive. I *think* this is how it should be done:

1. During the Installation choose Manual Install.

2. Follow the on screen instructions until the Main Menu screen.

3. From the main menu select:
Kernel modules (Hardware drivers)

4. Next select:
add driver update

5. Insert the cdrom disk containing your smart array driver(s)

6. Next select:
hdc (or wherever your cdrom is located) If you had a floppy drive you would select floppy if Driver Update disk is on the floppy)

7. Wait for Driver Updates Added, and hopefully the smart array 6i will show up in the window. Select OK.

8. Remove the smart array driver update disk and insert the SLES 8.x OS disk. Select Go Back.

9. From the Main Menu select:
Start Installation and follow the on screen prompts to complete the OS installation.

Hopefully this should work!
TIMOTHEE
Advisor

Re: No disk detected during SLES 8.1 install

Bryan

i don't have the "add driver update" offer on step 4 of your procedure

distribution is SLES 8.1 kernel 2.4-19

regards
Bryan Eley
Trusted Contributor
Solution

Re: No disk detected during SLES 8.1 install

Timothee,

I found some postings where the SLES 8 SP4 supports the SA 6i, FYI, so if you could get that version that might solve your problem without having to do any special driver update..

BTW, at bootup for install is there a "Press F6 for driver update" where you have the option of booting off hard drive, installation, rescue, etc. screen? It might be the left ALT key that needs to be pressed. I don't have my old test SLES 8 CDs in front of me to check. A link of HP's site for a different SCSI installation instruction states the following, but I'm not sure if it is specific to SLES 9 or not:
"Boot the...server from CD-ROM 1 of the base UnitedLinux 1.0 installation media (not CD-ROM 1 of SP2a). When the Linux \"boot\" screen is displayed, press the left ALT key to supply the driver diskette."
TIMOTHEE
Advisor

Re: No disk detected during SLES 8.1 install

hello bryan,

thanks again for your inputs

i somehow found the SLES SP3 CD and i'm going to check if i can get the SCSI controller recognised by using a USB external floppy

i found a procedure on another thread

i'll let you how it goes

thanks again for your help, it's much appreciated
Bryan Eley
Trusted Contributor

Re: No disk detected during SLES 8.1 install

Glad to, well, try to help. ;-)
I hope it works for you!
Bryan
TIMOTHEE
Advisor

Re: No disk detected during SLES 8.1 install

hello bryan

well it worked fine

i booted up on the SP3 CD and then used an external USB with a floppy containing the 6i controller module to be set during install-time
..then everything was ok

thanks a lot buddy

cheers
SIVAKUMAR.P
Frequent Advisor

Re: No disk detected during SLES 8.1 install

Hi Timothee,

Is it help for you.

First I tried to update the BIOS and Firmware and We are trying to load Red Hat
Enterprise server3.0 on a DL380 G4 with a smart array 6i controller, during the power on
Self test the system recognizes the 6i controller and created logical drive RAID1 (36GBX2NO'S).

The Red Hat Installation is not recognized the disk drivers and therefore it says
No place to install the operating system. The installation program is not finding the
Logical drive. During the installation we see the 'CCISS' driver attempt to and apparently
Successfully load, this should enable Red Hat to see the logical drive, but it does not detect.

I down loaded a new driver (cpq-cciss-2.4.50-30.rhel3.i386.dd.gz) from
The hp support site and have tried to load that drive but still problem persist.
Finally I download Red Hat Update3 Image from following site
(http://mirror.lnnu.edu.cn/01.iso/02.as3-updates3)and start the installation
It is working fine, because the Customer previous OS-Kernel Ver: 2.4.21-4 but download
OS-Kernel ver: 2.4.21-20.So it is problem with kernel Compatibility issues.
24/7 SUPPORT Mobile.No:919841509428
Bryan Eley
Trusted Contributor

Re: No disk detected during SLES 8.1 install

Timothee,

I'm glad you were able to get your server working. Good luck with it!
Bryan
TIMOTHEE
Advisor

Re: No disk detected during SLES 8.1 install

hello bryan and sivakumar

i agree with you sivakumar, i did exactly the same thing you described step by step except that my system is SuSE Enterprise Server 8.1 but the method is the same

using the SuSE SP3 cd (the equivalent of your RH SP Image) i upgraded the kernel, going 2-4-19 to 2-4.21 as a result of this operation, so that the new kernel has support for the last generation of controller

thanks all and have a nice day

cheers